<!DOCTYPE html>
<link rel="alternate" href="https://ecadforum.com/" hreflang="en-us" />
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
<meta charset="UTF-8" />
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="pingback" href="https://ecadforum.com/xmlrpc.php" />
<title>Confronting the past: Time Catches Up With &quot;EPRDF Dictatorship and Mafia Group&quot; in Ethiopia</title>

<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:title" content="Confronting the past: Time Catches Up With “EPRDF Dictatorship and Mafia Group” in #Ethiopia">
<meta name="twitter:description" content="Ethiopians know full well for years now this bunch had been on the take – often in cahoots with business leaders and others in their network. What happened to Gen Kinfe et al is the tip of the ice berg.">
<meta name="twitter:image" content="https://ecadforum.com/wp-content/uploads/2018/11/Kinfe-Dagnew-arrested.jpg">
<meta name="twitter:site" content="@ecadf">
<meta name="twitter:creator" content="@ecadf">




<link rel="author" href="https://plus.google.com/u/0/+EcadfEthiopiaNews/posts" />
<meta name="description" content="Ethiopians know full well for years now this bunch had been on the take – often in cahoots with business leaders and others in their network. What happened to Gen Kinfe et al is the tip of the ice berg." />
<meta name="keywords" content="opinions" />
<meta name="robots" content="index,nofollow" />
<link rel="canonical" href="https://ecadforum.com/2018/11/15/confronting-the-past-time-catches-up-with-eprdf-dictatorship-and-mafia-group-in-ethiopia/" />
<script type="text/javascript">
				window.ga=window.ga||function(){(ga.q=ga.q||[]).push(arguments)};ga.l=+new Date;
				ga('create', 'UA-9883609-1', 'auto');
				// Plugins
				
				ga('send', 'pageview');
			</script>
<script async src="https://www.google-analytics.com/analytics.js"></script>

<link rel="amphtml" href="https://ecadforum.com/2018/11/15/confronting-the-past-time-catches-up-with-eprdf-dictatorship-and-mafia-group-in-ethiopia/amp/" /><link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="ECADF Ethiopian News &raquo; Feed" href="https://ecadforum.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="ECADF Ethiopian News &raquo; Comments Feed" href="https://ecadforum.com/comments/feed/" />
<script>
var MP3jPLAYLISTS = [];
var MP3jPLAYERS = [];
</script>
<link rel="alternate" type="application/rss+xml" title="ECADF Ethiopian News &raquo; Confronting the past: Time Catches Up With “EPRDF Dictatorship and Mafia Group” in Ethiopia Comments Feed" href="https://ecadforum.com/2018/11/15/confronting-the-past-time-catches-up-with-eprdf-dictatorship-and-mafia-group-in-ethiopia/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/ecadforum.com\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='mashsb-styles-css' href='https://ecadforum.com/wp-content/plugins/mashsharer/assets/css/mashsb.min.css' type='text/css' media='all' />
<style id='mashsb-styles-inline-css' type='text/css'>
.mashsb-count {color:#9a9b9c;}
        [class^="mashicon-"], .onoffswitch-label, .onoffswitch2-label, .onoffswitch {
            border-radius: 2px;
        }@media only screen and (min-width:568px){.mashsb-buttons a {min-width: 177px;}}
</style>
<link rel='stylesheet' id='tie-style-css' href='https://ecadforum.com/wp-content/themes/jarida/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='Roboto+Condensed-css' href='https://fonts.googleapis.com/css?family=Roboto+Condensed%3A300%2C300italic%2Cregular%2Citalic%2C700%2C700italic' type='text/css' media='all' />
<link rel='stylesheet' id='Oswald-css' href='https://fonts.googleapis.com/css?family=Oswald%3Aregular%2C700' type='text/css' media='all' />
<link rel='stylesheet' id='open-sans-css' href='https://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400italic%2C600italic%2C300%2C400%2C600&#038;subset=latin%2Clatin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='mp3-jplayer-css' href='https://ecadforum.com/wp-content/plugins/mp3-jplayer/css/dark.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://c0.wp.com/p/jetpack/6.7/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript' src='https://c0.wp.com/c/4.9.8/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/4.9.8/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mashsb = {"shares":"546","round_shares":"1","animate_shares":"0","dynamic_buttons":"0","share_url":"https:\/\/ecadforum.com\/2018\/11\/15\/confronting-the-past-time-catches-up-with-eprdf-dictatorship-and-mafia-group-in-ethiopia\/","title":"Confronting+the+past%3A+Time+Catches+Up+With+%E2%80%9CEPRDF+Dictatorship+and+Mafia+Group%E2%80%9D+in+Ethiopia","image":"https:\/\/ecadforum.com\/wp-content\/uploads\/2018\/11\/Kinfe-Dagnew-arrested.jpg","desc":"Ethiopians know full well for years now this bunch had been on the take \u2013 often in cahoots with business leaders and others in their network. What happened to Gen Kinfe et al is the tip of the ice berg.","hashtag":"ecadf","subscribe":"content","subscribe_url":"","activestatus":"1","singular":"1","twitter_popup":"1","refresh":"1","nonce":"165e7e3da5","postid":"44017","servertime":"1542665055","ajaxurl":"https:\/\/ecadforum.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://ecadforum.com/wp-content/plugins/mashsharer/assets/js/mashsb.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/6.7/_inc/build/postmessage.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/6.7/_inc/build/jquery.jetpack-resize.min.js'></script>
<link rel='https://api.w.org/' href='https://ecadforum.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://ecadforum.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://ecadforum.com/wp-includes/wlwmanifest.xml" />
<link rel='prev' title='ESAT Latest Ethiopian News November 15, 2018' href='https://ecadforum.com/2018/11/15/esat-latest-ethiopian-news-november-15-2018/' />
<link rel='next' title='Reverse Ethiopia’s Institutional Void, and Hold TPLF Accountability' href='https://ecadforum.com/2018/11/16/reverse-ethiopias-institutional-void-and-hold-tplf-accountability/' />
<meta name="generator" content="WordPress 4.9.8" />
<link rel='shortlink' href='https://wp.me/p1u1FD-brX' />
<link rel="alternate" type="application/json+oembed" href="https://ecadforum.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fecadforum.com%2F2018%2F11%2F15%2Fconfronting-the-past-time-catches-up-with-eprdf-dictatorship-and-mafia-group-in-ethiopia%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://ecadforum.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fecadforum.com%2F2018%2F11%2F15%2Fconfronting-the-past-time-catches-up-with-eprdf-dictatorship-and-mafia-group-in-ethiopia%2F&#038;format=xml" />
<meta property="fb:app_id" content="787806777997466" />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel='dns-prefetch' href='//widgets.wp.com' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel="shortcut icon" href="https://ecadforum.com/wp-content/uploads/2015/10/ECADF-iPad-Icon.png" title="Favicon" /><!--[if IE]>
<script type="text/javascript">jQuery(document).ready(function (){ jQuery(".menu-item").has("ul").children("a").attr("aria-haspopup", "true");});</script>
<![endif]-->
<!--[if lt IE 9]>
<script src="https://ecadforum.com/wp-content/themes/jarida/js/html5.js"></script>
<script src="https://ecadforum.com/wp-content/themes/jarida/js/selectivizr-min.js"></script>
<![endif]-->
<!--[if IE 8]>
<link rel="stylesheet" type="text/css" media="all" href="https://ecadforum.com/wp-content/themes/jarida/css/ie8.css" />
<![endif]-->
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1" />
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1, user-scalable=no" />
<style type="text/css" media="screen">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</style>
<link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://ecadforum.com/wp-content/uploads/2015/10/ECADF-iPad-Retina-Icon.png" />
<link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://ecadforum.com/wp-content/uploads/2015/10/ECADF-iPhone-Retina-Icon.png" />
<link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://ecadforum.com/wp-content/uploads/2015/10/ECADF-iPad-Icon1.png" />
<link rel="apple-touch-icon-precomposed" href="https://ecadforum.com/wp-content/uploads/2015/10/ECADF-iPhone-Icon.png" />
<script src="//platform-api.sharethis.com/js/sharethis.js#property=58cf62ada754310012fd3782&product=gdpr-compliance-tool"></script>
<meta property="fb:pages" content="127102053997588" />
<meta property="fb:pages" content="127102053997588" />
<style type="text/css">.broken_link, a.broken_link {
	text-decoration: line-through;
}</style>

<meta property="og:type" content="article" />
<meta property="og:title" content="Confronting the past: Time Catches Up With “EPRDF Dictatorship and Mafia Group” in Ethiopia" />
<meta property="og:url" content="https://ecadforum.com/2018/11/15/confronting-the-past-time-catches-up-with-eprdf-dictatorship-and-mafia-group-in-ethiopia/" />
<meta property="og:description" content="Ethiopians know full well for years now this bunch had been on the take – often in cahoots with business leaders and others in their network. What happened to Gen Kinfe et al is the tip of the ice …" />
<meta property="article:published_time" content="2018-11-15T23:39:48+00:00" />
<meta property="article:modified_time" content="2018-11-15T23:39:50+00:00" />
<meta property="og:site_name" content="ECADF Ethiopian News" />
<meta property="og:image" content="https://ecadforum.com/wp-content/uploads/2018/11/Kinfe-Dagnew-arrested.jpg" />
<meta property="og:image:width" content="620" />
<meta property="og:image:height" content="330" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:creator" content="@ECADF" />
<meta name="twitter:site" content="@ECADF" />
<meta name="twitter:text:title" content="Confronting the past: Time Catches Up With “EPRDF Dictatorship and Mafia Group” in Ethiopia" />
<meta name="twitter:image" content="https://ecadforum.com/wp-content/uploads/2018/11/Kinfe-Dagnew-arrested.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-4379286819423322",
          enable_page_level_ads: true
     });
</script>
</head>
<body id="top" class="post-template-default single single-post postid-44017 single-format-standard">
<div class="background-cover"></div>
<div class="wrapper">
<div class="container">
<header id="theme-header">
<div class="header-content fade-in animated1">
<div class="logo">
<h2> <a title="ECADF Ethiopian News" href="https://ecadforum.com/">
<img src="https://ecadforum.com/wp-content/uploads/2017/08/ecadf-logo-2017.png" alt="ECADF Ethiopian News" /><strong>ECADF Ethiopian News Ethiopian news, video and opinions.</strong>
</a>
</h2> </div>
<div class="clear"></div>
</div>
<nav id="main-nav" class="fade-in animated2">
<div class="container">
<div class="main-menu"><ul id="menu-category" class="menu"><li id="menu-item-601" class="menu-item  menu-item-type-custom  menu-item-object-custom  menu-item-home"><a href="https://ecadforum.com">Home</a></li>
<li id="menu-item-7476" class="menu-item  menu-item-type-custom  menu-item-object-custom"><a href="https://www.ecadforum.com/Amharic/">Amharic</a></li>
<li id="menu-item-26255" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="https://ecadforum.com/category/video/">Video</a></li>
<li id="menu-item-37780" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="https://ecadforum.com/category/ethiopianmusic/">Music Video</a></li>
<li id="menu-item-14642" class="menu-item  menu-item-type-custom  menu-item-object-custom"><a title="VOA Amharic radio" href="https://ecadforum.com/voa-amharic-radio-daily-broadcast-to-ethiopia/">VOA</a></li>
<li id="menu-item-26052" class="menu-item  menu-item-type-custom  menu-item-object-custom  menu-item-has-children"><a>Categories</a>
<ul class="sub-menu">
<li id="menu-item-26047" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="https://ecadforum.com/category/news/">News</a></li>
<li id="menu-item-26049" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a rel="nofollow" href="https://ecadforum.com/category/video/">Video</a></li>
<li id="menu-item-37782" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a rel="nofollow" href="https://ecadforum.com/category/ethiopianmusic/">Music Video</a></li>
<li id="menu-item-26048" class="menu-item  menu-item-type-taxonomy  menu-item-object-category  current-post-ancestor  current-menu-parent  current-post-parent"><a href="https://ecadforum.com/category/opinion/">Opinions</a></li>
<li id="menu-item-26050" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="https://ecadforum.com/category/events/">Events</a></li>
<li id="menu-item-26051" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="https://ecadforum.com/category/sport/">Sport</a></li>
</ul> 
</li>
<li id="menu-item-28217" class="menu-item  menu-item-type-custom  menu-item-object-custom  menu-item-has-children"><a>Social media</a>
<ul class="sub-menu">
<li id="menu-item-25967" class="menu-item  menu-item-type-custom  menu-item-object-custom"><a rel="nofollow" href="https://www.facebook.com/ethiopianews">Facebook</a></li>
<li id="menu-item-25968" class="menu-item  menu-item-type-custom  menu-item-object-custom"><a rel="nofollow" href="https://twitter.com/ECADF">Twitter</a></li>
<li id="menu-item-25969" class="menu-item  menu-item-type-custom  menu-item-object-custom"><a rel="nofollow" href="https://www.youtube.com/user/ecadfethiopia/videos">YouTube</a></li>
<li id="menu-item-7006" class="menu-item  menu-item-type-custom  menu-item-object-custom"><a rel="nofollow" href="https://ecadforum.com/ecadf-chat-room/">Paltalk</a></li>
</ul> 
</li>
<li id="menu-item-38672" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="https://ecadforum.com/archive/">Archive</a></li>
<li id="menu-item-26010" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="https://ecadforum.com/contact-2/">Contact Us</a></li>
</ul></div> </div>
</nav>
</header>
<div id="main-content" class="container fade-in animated3 sidebar-narrow-left">
<div class="content-wrap">
<div class="content">
<article id="the-post" class="post-listing post-44017 post type-post status-publish format-standard has-post-thumbnail hentry category-opinion">
<div class="post-inner">
<h1 class="name post-title entry-title" itemprop="itemReviewed" itemscope itemtype="http://schema.org/Thing"><span itemprop="name">Confronting the past: Time Catches Up With “EPRDF Dictatorship and Mafia Group” in Ethiopia</span></h1>
<p class="post-meta">
<span class="post-meta-author">Posted by: <a href="https://ecadforum.com/author/ecadforum/" title="">ecadforum </a></span>
<span class="post-cats">in <a href="https://ecadforum.com/category/opinion/" rel="category tag">Opinions</a></span>
<span class="tie-date">November 15, 2018</span>
</p>
<div class="clear"></div>
<div class="entry">
<aside class="mashsb-container mashsb-main mashsb-stretched">
<div class="mashsb-box">
<div class="mashsb-count mash-large" style="float:left;">
<div class="counts mashsbcount">546</div>
<p><span class="mashsb-sharetext">SHARES</span></div>
<div class="mashsb-buttons"><a class="mashicon-facebook mash-large mash-center mashsb-noshadow" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fecadforum.com%2F2018%2F11%2F15%2Fconfronting-the-past-time-catches-up-with-eprdf-dictatorship-and-mafia-group-in-ethiopia%2F" target="_blank" rel="noopener nofollow"><span class="icon"></span><span class="text">Share</span></a><a class="mashicon-twitter mash-large mash-center mashsb-noshadow" href="https://twitter.com/intent/tweet?text=Confronting%20the%20past%3A%20Time%20Catches%20Up%20With%20%E2%80%9CEPRDF%20Dictatorship%20and%20Mafia%20Group%E2%80%9D%20in%20%23Ethiopia&#038;url=https://ecadforum.com/2018/11/15/confronting-the-past-time-catches-up-with-eprdf-dictatorship-and-mafia-group-in-ethiopia/&#038;via=ecadf" target="_blank" rel="noopener nofollow"><span class="icon"></span><span class="text">Tweet</span></a></p>
<div class="onoffswitch2 mash-large mashsb-noshadow" style="display:none;"></div>
</div></div>
<div style="clear:both;"></div>
<div class="mashsb-toggle-container"></div>
</aside>
<p> <em>by Zekarias Ezra</em></p>
<p><a href="https://ecadforum.com/2018/11/15/confronting-the-past-time-catches-up-with-eprdf-dictatorship-and-mafia-group-in-ethiopia/kinfe-dagnew-arrested/" rel="attachment wp-att-44018"><img class="aligncenter size-large wp-image-44018" src="https://ecadforum.com/wp-content/uploads/2018/11/Kinfe-Dagnew-arrested-620x330.jpg" alt="What happened to Gen Kinfe et al is the tip of the ice berg." width="620" height="330" srcset="https://ecadforum.com/wp-content/uploads/2018/11/Kinfe-Dagnew-arrested.jpg 620w, https://ecadforum.com/wp-content/uploads/2018/11/Kinfe-Dagnew-arrested-150x80.jpg 150w, https://ecadforum.com/wp-content/uploads/2018/11/Kinfe-Dagnew-arrested-300x160.jpg 300w" sizes="(max-width: 620px) 100vw, 620px" /></a></p>
<p>They  stole millions to fund their lavish lifestyles and build their extravagant homes. They wantonly depleted the country’s resources. They tortured, maimed, and killed thousands. While keeping up the veneer of democracy with their sham elections and laughable ‘peaceful transfer of power’, they managed to retain power for long 27 years and counting. In the process, they quashed the hopes and dreams of citizens to freely elect their own leaders.</p>
<p>Ethiopians know full well for years now this bunch had been on the take – often in cahoots with business leaders and others in their network. What happened to Gen Kinfe et al is the tip of the ice berg.</p>
<p>Dictators, like the EPRDF bunch, used to think they would end up their days somewhere they would be safe. But now instead of having a house in Harare, like Mengistu, they might end up in The Hague in the International Criminal Court.</p>
<p>Ethiopia is in defacto transition resembling the ones it had in 1974 and 1991. As in any transition, a political debate must center on two key issues. That is, the issue of how to deal with past human rights abuses and looting and how to prevent abuses from occurring in the future. Countries in the past have dealt with this issue by establishing commissions of inquiry. There is still debate among international human rights practitioners on the effectiveness of such commissions.</p>
<p>The issue of Retribution vs. Reconciliation has now come to the forefront with the arrest, first, of the Abdi Ali and now with Gen Kinfe and others. The issue is an old one that haunts all emerging democracies. In January 1793, the French parliament spent three agonizing days debating how to punish King Louis XVI before deciding to send him to the guillotine.</p>
<p>How do we now proceed? Curbing flared up emotions and passions,  Ethiopians must hold ‘town hall’ debate in their communities to chart a path for a long-lasting solution. In 1991, Meles Zenawi and his team were struggling with the same issue in the aftermath of the Mengistu regime having in custody thousands of people suspected of committing serious crimes.</p>
<p>Have they learned anything? The answer must now be clear. We are, as a nation, in the same predicament as we were in 1991. We must avoid the repeat of that mistake. That is exactly why, as a nation we must answer once and for all the issue of Retribution vs Reconciliation. The appropriate moral response is but to dispense justice.</p>
<p>How do we achieve a <strong>just solution</strong> that is acceptable to a long-suffering population and at the same time steers clear of both witch-hunts and whitewashes? However, moving the victims&#8217; demand for justice might be, we, as a nation, must still weigh the risks of starting a process that could frighten the military or other forces linked to the crimes enough to jeopardize the democratic transition. That should be a decision the Ethiopian people must make.</p>
<p>Now that the government has started taking into custody those suspected of crimes, we must but ask the question ‘what about the rest of the gang members?</p>
<p>It is an official secret hat the arrested people did not commit the ‘crimes’ alone. There is a web of network from one corner to another that scramble the country as a hyena devours its prey.   More importantly, EPRDF and its leaders and its cadres must be held to account as well. It would be a mockery of justice to see top echelon of the mafia group go unpunished and even disgusting to see them still at the helm of power.</p>
<p>EPRDF simply has no moral ground to execute a just retribution. I believe that might be why Dr Abiy correctly preached about and called for forgiveness.</p>
<p>I agree in principle with Dr Abiy when he said</p>
<p><strong>“I call on us all to forgive each other from our hearts; to close the chapters from yesterday, </strong><strong>and to the forge ahead to next bright future through national consensus.”</strong></p>
<p>Should the facts on the ground necessitates a course change it then ought to be done in a transparent and just manner. That entails knocking at the doors of every top leader, past and present, within EPRDF.   Is the government ready to turn against itself in such a dramatic way?</p>
<p>EPRDF could go in the annals of history as a political organization that right its wrong if it were to prepare a path for a free and fair election, by taking itself out of competition from the upcoming election, and hand over power to a freely elected government while in the interim facilitating a ‘National Reconciliation’ in the manner of South Africa.</p>
<div class="fb-comments" data-href="https://ecadforum.com/2018/11/15/confronting-the-past-time-catches-up-with-eprdf-dictatorship-and-mafia-group-in-ethiopia/" data-numposts="10" data-width="" data-colorscheme="light"></div>
</div>
<span style="display:none" class="updated">2018-11-15</span>
<div style="display:none" class="vcard author" itemprop="author" itemscope itemtype="http://schema.org/Person"><strong class="fn" itemprop="name"><a href="https://plus.google.com/u/0/b/113621583050101745316/+Ecadforumethiopia/posts?rel=author">+ecadforum</a></strong></div>
</div>
</article>
<div id="comments">
<h3 id="comments-title">
6 comments </h3>
<ol class="commentlist"> <li id="comment-456103">
<div class="comment even thread-even depth-1 comment-wrap">
<div class="comment-avatar"><img alt='' src='https://secure.gravatar.com/avatar/ce7c5701faeb76e2d900140233885b49?s=45&#038;d=https%3A%2F%2Fecadforum.com%2Fwp-content%2Fuploads%2F2015%2F11%2FECADF_Gravatar.png&#038;r=g' srcset='https://secure.gravatar.com/avatar/ce7c5701faeb76e2d900140233885b49?s=90&#038;d=https%3A%2F%2Fecadforum.com%2Fwp-content%2Fuploads%2F2015%2F11%2FECADF_Gravatar.png&#038;r=g 2x' class='avatar avatar-45 photo' height='45' width='45' /></div>
<div class="author-comment">
<cite class="fn">TPLF is the Poison</cite> <div class="comment-meta commentmetadata"><a href="https://ecadforum.com/2018/11/15/confronting-the-past-time-catches-up-with-eprdf-dictatorship-and-mafia-group-in-ethiopia/#comment-456103"> November 16, 2018 at 2:08 pm</a></div>
</div>
<div class="clear"></div>
<div class="comment-content">
<p>TPLF made, ordered and controlled EPRDF. TPLF looted and devoured Ethiopia&#8217;s resources by dividing people . It made harmonious Ethiopians to see each other as enemies instead of countrymen that lived together for centuries.</p>
<p>TPLF ordered the maiming, killings, torturing, raping of women and men prisoners including ethnically targeted sexual dysfunctions in males so that they will not be able to have sex and bear children.</p>
<p>TPLF is the poison of Ethiopia and Ethiopians that came up with the poisonous policy.</p>
<p>EPRDF members were picking up the left overs. Many participated in crimes against their own people.</p>
<p>Some like Dr. Abiy had a change of heart and stopped following TPLF poisonous policy. That is what we see today.</p>
</div>
<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://ecadforum.com/2018/11/15/confronting-the-past-time-catches-up-with-eprdf-dictatorship-and-mafia-group-in-ethiopia/?replytocom=456103#respond' onclick='return addComment.moveForm( "comment-456103", "456103", "respond", "44017" )' aria-label='Reply to TPLF is the Poison'>Reply</a></div>
</div>
<ul class="children">
<li id="comment-456107">
<div class="comment odd alt depth-2 comment-wrap">
<div class="comment-avatar"><img alt='' src='https://secure.gravatar.com/avatar/e4eea2e77a531435fab56bad31917e78?s=45&#038;d=https%3A%2F%2Fecadforum.com%2Fwp-content%2Fuploads%2F2015%2F11%2FECADF_Gravatar.png&#038;r=g' srcset='https://secure.gravatar.com/avatar/e4eea2e77a531435fab56bad31917e78?s=90&#038;d=https%3A%2F%2Fecadforum.com%2Fwp-content%2Fuploads%2F2015%2F11%2FECADF_Gravatar.png&#038;r=g 2x' class='avatar avatar-45 photo' height='45' width='45' /></div>
<div class="author-comment">
<cite class="fn">zekarias</cite> <div class="comment-meta commentmetadata"><a href="https://ecadforum.com/2018/11/15/confronting-the-past-time-catches-up-with-eprdf-dictatorship-and-mafia-group-in-ethiopia/#comment-456107"> November 17, 2018 at 11:12 pm</a></div>
</div>
<div class="clear"></div>
<div class="comment-content">
<p>I did not know a &#8216;change of heart&#8217; is an exonerating circumstance that is accepted in a court of law. It could help as a mitigating circumstance for leniency of punishment. Other than that, telling the Ethiopian people all the rest of the EPRDF leadership including this PM and his predecessors are clean of all crimes does not hold water. That is why, some of us have argued the better path is for EPRDF to relinquish power fully and start a path of national reconciliation.</p>
</div>
<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://ecadforum.com/2018/11/15/confronting-the-past-time-catches-up-with-eprdf-dictatorship-and-mafia-group-in-ethiopia/?replytocom=456107#respond' onclick='return addComment.moveForm( "comment-456107", "456107", "respond", "44017" )' aria-label='Reply to zekarias'>Reply</a></div>
</div>
</li>
</ul>
</li>
<li id="comment-456100">
<div class="comment even thread-odd thread-alt depth-1 comment-wrap">
<div class="comment-avatar"><img alt='' src='https://secure.gravatar.com/avatar/ed8fc198e9a73ab87b2ff82bffd02f45?s=45&#038;d=https%3A%2F%2Fecadforum.com%2Fwp-content%2Fuploads%2F2015%2F11%2FECADF_Gravatar.png&#038;r=g' srcset='https://secure.gravatar.com/avatar/ed8fc198e9a73ab87b2ff82bffd02f45?s=90&#038;d=https%3A%2F%2Fecadforum.com%2Fwp-content%2Fuploads%2F2015%2F11%2FECADF_Gravatar.png&#038;r=g 2x' class='avatar avatar-45 photo' height='45' width='45' /></div>
<div class="author-comment">
<cite class="fn">Ahmef</cite> <div class="comment-meta commentmetadata"><a href="https://ecadforum.com/2018/11/15/confronting-the-past-time-catches-up-with-eprdf-dictatorship-and-mafia-group-in-ethiopia/#comment-456100"> November 16, 2018 at 12:38 am</a></div>
</div>
<div class="clear"></div>
<div class="comment-content">
<p>Agreed with most of your ideas but I don&#8217;t think EPRD including TPLF can be the judge and jury at the same time should<br />
the path of ristitution and dispensing of justice applied without exception.</p>
</div>
<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://ecadforum.com/2018/11/15/confronting-the-past-time-catches-up-with-eprdf-dictatorship-and-mafia-group-in-ethiopia/?replytocom=456100#respond' onclick='return addComment.moveForm( "comment-456100", "456100", "respond", "44017" )' aria-label='Reply to Ahmef'>Reply</a></div>
</div>
</li>
<li id="comment-456099">
<div class="comment odd alt thread-even depth-1 comment-wrap">
<div class="comment-avatar"><img alt='' src='https://secure.gravatar.com/avatar/de1058a3d18cf5edfb6a4014b658a3bb?s=45&#038;d=https%3A%2F%2Fecadforum.com%2Fwp-content%2Fuploads%2F2015%2F11%2FECADF_Gravatar.png&#038;r=g' srcset='https://secure.gravatar.com/avatar/de1058a3d18cf5edfb6a4014b658a3bb?s=90&#038;d=https%3A%2F%2Fecadforum.com%2Fwp-content%2Fuploads%2F2015%2F11%2FECADF_Gravatar.png&#038;r=g 2x' class='avatar avatar-45 photo' height='45' width='45' /></div>
<div class="author-comment">
<cite class="fn">Zekarias</cite> <div class="comment-meta commentmetadata"><a href="https://ecadforum.com/2018/11/15/confronting-the-past-time-catches-up-with-eprdf-dictatorship-and-mafia-group-in-ethiopia/#comment-456099"> November 15, 2018 at 7:34 pm</a></div>
</div>
<div class="clear"></div>
<div class="comment-content">
<p>Teddy, no need to suspect. Kindly read my previous writings as way back as 2009. EPRDF is nothing but TPLF in essence. But if I use TPLF only, some would want to see EPRDF different than TPLF. My contention is the whole EPRDF is contaminated.</p>
</div>
<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://ecadforum.com/2018/11/15/confronting-the-past-time-catches-up-with-eprdf-dictatorship-and-mafia-group-in-ethiopia/?replytocom=456099#respond' onclick='return addComment.moveForm( "comment-456099", "456099", "respond", "44017" )' aria-label='Reply to Zekarias'>Reply</a></div>
</div>
</li>
<li id="comment-456097">
<div class="comment even thread-odd thread-alt depth-1 comment-wrap">
<div class="comment-avatar"><img alt='' src='https://secure.gravatar.com/avatar/2a24a0bf40d96e3d525bbcd090dacffc?s=45&#038;d=https%3A%2F%2Fecadforum.com%2Fwp-content%2Fuploads%2F2015%2F11%2FECADF_Gravatar.png&#038;r=g' srcset='https://secure.gravatar.com/avatar/2a24a0bf40d96e3d525bbcd090dacffc?s=90&#038;d=https%3A%2F%2Fecadforum.com%2Fwp-content%2Fuploads%2F2015%2F11%2FECADF_Gravatar.png&#038;r=g 2x' class='avatar avatar-45 photo' height='45' width='45' /></div>
<div class="author-comment">
<cite class="fn">Teddy</cite> <div class="comment-meta commentmetadata"><a href="https://ecadforum.com/2018/11/15/confronting-the-past-time-catches-up-with-eprdf-dictatorship-and-mafia-group-in-ethiopia/#comment-456097"> November 15, 2018 at 3:50 pm</a></div>
</div>
<div class="clear"></div>
<div class="comment-content">
<p>EPRDF was made by TPLF, and TPLF controls EPRDF for the last 27 years. Ironically the writer managed to avoid the word &#8220;TPLF&#8221; in the entire article. The intent is suspicious to say the least.</p>
</div>
<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://ecadforum.com/2018/11/15/confronting-the-past-time-catches-up-with-eprdf-dictatorship-and-mafia-group-in-ethiopia/?replytocom=456097#respond' onclick='return addComment.moveForm( "comment-456097", "456097", "respond", "44017" )' aria-label='Reply to Teddy'>Reply</a></div>
</div>
<ul class="children">
<li id="comment-456098">
<div class="comment odd alt depth-2 comment-wrap">
<div class="comment-avatar"><img alt='' src='https://secure.gravatar.com/avatar/f9fe04afa18304fe17f7e24d3ffef261?s=45&#038;d=https%3A%2F%2Fecadforum.com%2Fwp-content%2Fuploads%2F2015%2F11%2FECADF_Gravatar.png&#038;r=g' srcset='https://secure.gravatar.com/avatar/f9fe04afa18304fe17f7e24d3ffef261?s=90&#038;d=https%3A%2F%2Fecadforum.com%2Fwp-content%2Fuploads%2F2015%2F11%2FECADF_Gravatar.png&#038;r=g 2x' class='avatar avatar-45 photo' height='45' width='45' /></div>
<div class="author-comment">
<cite class="fn">D Hiwet</cite> <div class="comment-meta commentmetadata"><a href="https://ecadforum.com/2018/11/15/confronting-the-past-time-catches-up-with-eprdf-dictatorship-and-mafia-group-in-ethiopia/#comment-456098"> November 15, 2018 at 4:18 pm</a></div>
</div>
<div class="clear"></div>
<div class="comment-content">
<p>Be it intentional or otherwise EPRDF was the main vehicle used to loot and kill the Horn!!!</p>
</div>
<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://ecadforum.com/2018/11/15/confronting-the-past-time-catches-up-with-eprdf-dictatorship-and-mafia-group-in-ethiopia/?replytocom=456098#respond' onclick='return addComment.moveForm( "comment-456098", "456098", "respond", "44017" )' aria-label='Reply to D Hiwet'>Reply</a></div>
</div>
</li>
</ul>
</li>
</ol>
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Comments — What do you think? <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2018/11/15/confronting-the-past-time-catches-up-with-eprdf-dictatorship-and-mafia-group-in-ethiopia/#respond" style="display:none;">Cancel reply</a></small>
</h3>
<form id="commentform" class="comment-form">
<iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=21932601&#038;postid=44017&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=https%3A%2F%2Fecadforum.com%2Fwp-content%2Fuploads%2F2015%2F11%2FECADF_Gravatar.png&#038;greeting=Comments+%E2%80%94+What+do+you+think%3F&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=6.7&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;sig=ed0690fcda09d1a7bd0b96f2075c5bebbf8c7e5d#parent=https%3A%2F%2Fecadforum.com%2F2018%2F11%2F15%2Fconfronting-the-past-time-catches-up-with-eprdf-dictatorship-and-mafia-group-in-ethiopia%2F" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"></iframe>
<!--[if !IE]><!-->
<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
<!--<![endif]-->
</form>
</div>
<input type="hidden" name="comment_parent" id="comment_parent" value="" />
</div>
<section id="related_posts">
<div class="block-head">
<h3>Related Posts</h3><div class="stripe-line"></div>
</div>
<div class="post-listing">
<div class="related-item">
<div class="post-thumbnail">
<a href="https://ecadforum.com/2018/11/19/esat-latest-ethiopian-news-60-minutes-november-19-2018/" title="Permalink to ESAT Latest Ethiopian News (60 Minutes) November 19, 2018" rel="bookmark">
<img width="300" height="160" src="https://ecadforum.com/wp-content/uploads/2018/11/ESAT-News-November-19-2018-300x160.jpg" class="attachment-tie-large size-tie-large wp-post-image" alt="ESAT Latest Ethiopian News (60 Minutes) November 19, 2018." srcset="https://ecadforum.com/wp-content/uploads/2018/11/ESAT-News-November-19-2018-300x160.jpg 300w, https://ecadforum.com/wp-content/uploads/2018/11/ESAT-News-November-19-2018-150x80.jpg 150w, https://ecadforum.com/wp-content/uploads/2018/11/ESAT-News-November-19-2018.jpg 620w" sizes="(max-width: 300px) 100vw, 300px" /> </a>
</div>
<h3><a href="https://ecadforum.com/2018/11/19/esat-latest-ethiopian-news-60-minutes-november-19-2018/" title="Permalink to ESAT Latest Ethiopian News (60 Minutes) November 19, 2018" rel="bookmark">ESAT Latest Ethiopian News (60 Minutes) November 19, 2018</a></h3>
<p class="post-meta"><span class="tie-date">November 19, 2018</span></p>
</div>
<div class="related-item">
<div class="post-thumbnail">
<a href="https://ecadforum.com/2018/11/18/the-women-smashing-ethiopias-glass-ceiling/" title="Permalink to The women smashing Ethiopia&#8217;s glass ceiling" rel="bookmark">
<img width="300" height="160" src="https://ecadforum.com/wp-content/uploads/2018/11/Lawyer-Meaza-Ashenafi-300x160.jpg" class="attachment-tie-large size-tie-large wp-post-image" alt="Prominent Ethiopian human rights lawyer Meaza Ashenafi." srcset="https://ecadforum.com/wp-content/uploads/2018/11/Lawyer-Meaza-Ashenafi-300x160.jpg 300w, https://ecadforum.com/wp-content/uploads/2018/11/Lawyer-Meaza-Ashenafi-150x80.jpg 150w, https://ecadforum.com/wp-content/uploads/2018/11/Lawyer-Meaza-Ashenafi.jpg 620w" sizes="(max-width: 300px) 100vw, 300px" /> </a>
</div>
<h3><a href="https://ecadforum.com/2018/11/18/the-women-smashing-ethiopias-glass-ceiling/" title="Permalink to The women smashing Ethiopia&#8217;s glass ceiling" rel="bookmark">The women smashing Ethiopia&#8217;s glass ceiling</a></h3>
<p class="post-meta"><span class="tie-date">November 18, 2018</span></p>
</div>
<div class="related-item">
<div class="post-thumbnail">
<a href="https://ecadforum.com/2018/11/16/ethiopia-issues-arrest-warrant-for-fugitive-ex-spy-chief-over-alleged-human-rights-abuses/" title="Permalink to Ethiopia issues arrest warrant for fugitive ex-spy chief over alleged human rights abuses" rel="bookmark">
<img width="300" height="160" src="https://ecadforum.com/wp-content/uploads/2018/11/Getachew-Assefa-300x160.jpg" class="attachment-tie-large size-tie-large wp-post-image" alt="Ex-spy chief, Getachew Assefa." srcset="https://ecadforum.com/wp-content/uploads/2018/11/Getachew-Assefa-300x160.jpg 300w, https://ecadforum.com/wp-content/uploads/2018/11/Getachew-Assefa-150x80.jpg 150w, https://ecadforum.com/wp-content/uploads/2018/11/Getachew-Assefa.jpg 620w" sizes="(max-width: 300px) 100vw, 300px" /> </a>
</div>
<h3><a href="https://ecadforum.com/2018/11/16/ethiopia-issues-arrest-warrant-for-fugitive-ex-spy-chief-over-alleged-human-rights-abuses/" title="Permalink to Ethiopia issues arrest warrant for fugitive ex-spy chief over alleged human rights abuses" rel="bookmark">Ethiopia issues arrest warrant for fugitive ex-spy chief over alleged human rights abuses</a></h3>
<p class="post-meta"><span class="tie-date">November 16, 2018</span></p>
</div>
<div class="related-item">
<div class="post-thumbnail">
<a href="https://ecadforum.com/2018/11/16/reverse-ethiopias-institutional-void-and-hold-tplf-accountability/" title="Permalink to Reverse Ethiopia’s Institutional Void, and Hold TPLF Accountability" rel="bookmark">
<img width="300" height="160" src="https://ecadforum.com/wp-content/uploads/2018/11/Addis-Ababa-Ethiopia-300x160.jpg" class="attachment-tie-large size-tie-large wp-post-image" alt="Developing Ethiopia&#039;s capital Addis Ababa." srcset="https://ecadforum.com/wp-content/uploads/2018/11/Addis-Ababa-Ethiopia-300x160.jpg 300w, https://ecadforum.com/wp-content/uploads/2018/11/Addis-Ababa-Ethiopia-150x80.jpg 150w, https://ecadforum.com/wp-content/uploads/2018/11/Addis-Ababa-Ethiopia.jpg 620w" sizes="(max-width: 300px) 100vw, 300px" /> </a>
</div>
<h3><a href="https://ecadforum.com/2018/11/16/reverse-ethiopias-institutional-void-and-hold-tplf-accountability/" title="Permalink to Reverse Ethiopia’s Institutional Void, and Hold TPLF Accountability" rel="bookmark">Reverse Ethiopia’s Institutional Void, and Hold TPLF Accountability</a></h3>
<p class="post-meta"><span class="tie-date">November 16, 2018</span></p>
</div>
<div class="related-item">
<div class="post-thumbnail">
<a href="https://ecadforum.com/2018/11/15/esat-latest-ethiopian-news-november-15-2018/" title="Permalink to ESAT Latest Ethiopian News November 15, 2018" rel="bookmark">
<img width="300" height="160" src="https://ecadforum.com/wp-content/uploads/2018/11/ESAT-News-November-15-2018-300x160.jpg" class="attachment-tie-large size-tie-large wp-post-image" alt="ESAT Latest Ethiopian News November 15, 2018." srcset="https://ecadforum.com/wp-content/uploads/2018/11/ESAT-News-November-15-2018-300x160.jpg 300w, https://ecadforum.com/wp-content/uploads/2018/11/ESAT-News-November-15-2018-150x80.jpg 150w, https://ecadforum.com/wp-content/uploads/2018/11/ESAT-News-November-15-2018.jpg 620w" sizes="(max-width: 300px) 100vw, 300px" /> </a>
</div>
<h3><a href="https://ecadforum.com/2018/11/15/esat-latest-ethiopian-news-november-15-2018/" title="Permalink to ESAT Latest Ethiopian News November 15, 2018" rel="bookmark">ESAT Latest Ethiopian News November 15, 2018</a></h3>
<p class="post-meta"><span class="tie-date">November 15, 2018</span></p>
</div>
<div class="related-item">
<div class="post-thumbnail">
<a href="https://ecadforum.com/2018/11/15/ethiopia-arrests-former-deputy-spy-chief-yared-zerihun/" title="Permalink to Ethiopia arrests former deputy spy chief Yared Zerihun" rel="bookmark">
<img width="300" height="160" src="https://ecadforum.com/wp-content/uploads/2018/11/Yared-Zerihun-arrested-300x160.jpg" class="attachment-tie-large size-tie-large wp-post-image" alt="Ethiopia arrested Yared Zerihun, former deputy intelligence chief.." srcset="https://ecadforum.com/wp-content/uploads/2018/11/Yared-Zerihun-arrested-300x160.jpg 300w, https://ecadforum.com/wp-content/uploads/2018/11/Yared-Zerihun-arrested-150x80.jpg 150w, https://ecadforum.com/wp-content/uploads/2018/11/Yared-Zerihun-arrested.jpg 620w" sizes="(max-width: 300px) 100vw, 300px" /> </a>
</div>
<h3><a href="https://ecadforum.com/2018/11/15/ethiopia-arrests-former-deputy-spy-chief-yared-zerihun/" title="Permalink to Ethiopia arrests former deputy spy chief Yared Zerihun" rel="bookmark">Ethiopia arrests former deputy spy chief Yared Zerihun</a></h3>
<p class="post-meta"><span class="tie-date">November 15, 2018</span></p>
</div>
<div class="related-item">
<div class="post-thumbnail">
<a href="https://ecadforum.com/2018/11/15/esats-letter-to-bbc-director-general-tony-hall/" title="Permalink to ESAT’s letter to BBC Director-General Tony Hall" rel="bookmark">
<img width="300" height="160" src="https://ecadforum.com/wp-content/uploads/2018/11/ESAT-to-BBC-300x160.jpg" class="attachment-tie-large size-tie-large wp-post-image" alt="ESAT’s letter to BBC." srcset="https://ecadforum.com/wp-content/uploads/2018/11/ESAT-to-BBC-300x160.jpg 300w, https://ecadforum.com/wp-content/uploads/2018/11/ESAT-to-BBC-150x80.jpg 150w, https://ecadforum.com/wp-content/uploads/2018/11/ESAT-to-BBC.jpg 620w" sizes="(max-width: 300px) 100vw, 300px" /> </a>
</div>
<h3><a href="https://ecadforum.com/2018/11/15/esats-letter-to-bbc-director-general-tony-hall/" title="Permalink to ESAT’s letter to BBC Director-General Tony Hall" rel="bookmark">ESAT’s letter to BBC Director-General Tony Hall</a></h3>
<p class="post-meta"><span class="tie-date">November 15, 2018</span></p>
</div>
<div class="related-item">
<div class="post-thumbnail">
<a href="https://ecadforum.com/2018/11/14/esat-latest-ethiopian-news-november-14-2018/" title="Permalink to ESAT Latest Ethiopian News November 14, 2018" rel="bookmark">
<img width="300" height="160" src="https://ecadforum.com/wp-content/uploads/2018/11/ESAT-News-November-14-2018-300x160.jpg" class="attachment-tie-large size-tie-large wp-post-image" alt="ESAT Latest Ethiopian News November 14, 2018." srcset="https://ecadforum.com/wp-content/uploads/2018/11/ESAT-News-November-14-2018-300x160.jpg 300w, https://ecadforum.com/wp-content/uploads/2018/11/ESAT-News-November-14-2018-150x80.jpg 150w, https://ecadforum.com/wp-content/uploads/2018/11/ESAT-News-November-14-2018.jpg 620w" sizes="(max-width: 300px) 100vw, 300px" /> </a>
</div>
<h3><a href="https://ecadforum.com/2018/11/14/esat-latest-ethiopian-news-november-14-2018/" title="Permalink to ESAT Latest Ethiopian News November 14, 2018" rel="bookmark">ESAT Latest Ethiopian News November 14, 2018</a></h3>
<p class="post-meta"><span class="tie-date">November 14, 2018</span></p>
</div>
<div class="related-item">
<div class="post-thumbnail">
<a href="https://ecadforum.com/2018/11/14/eritrea-sanctions-lifted-after-nine-years/" title="Permalink to Eritrea sanctions lifted after nine years" rel="bookmark">
<img width="300" height="160" src="https://ecadforum.com/wp-content/uploads/2018/07/Abiy-and-Isaias-holding-hands-300x160.jpg" class="attachment-tie-large size-tie-large wp-post-image" alt="Eritrean President Isaias Afwerki, and Ethiopia&#039;s Prime Minister Abiy Ahmed." srcset="https://ecadforum.com/wp-content/uploads/2018/07/Abiy-and-Isaias-holding-hands-300x160.jpg 300w, https://ecadforum.com/wp-content/uploads/2018/07/Abiy-and-Isaias-holding-hands-150x80.jpg 150w, https://ecadforum.com/wp-content/uploads/2018/07/Abiy-and-Isaias-holding-hands.jpg 620w" sizes="(max-width: 300px) 100vw, 300px" /> </a>
</div>
<h3><a href="https://ecadforum.com/2018/11/14/eritrea-sanctions-lifted-after-nine-years/" title="Permalink to Eritrea sanctions lifted after nine years" rel="bookmark">Eritrea sanctions lifted after nine years</a></h3>
<p class="post-meta"><span class="tie-date">November 14, 2018</span></p>
</div>
<div class="clear"></div>
</div>
</section>
</div>
<aside class="sidebar-narrow">
<div id="posts-list-widget-2" class="widget posts-list"><div class="widget-top"><h4>Recent Posts </h4><div class="stripe-line"></div></div>
<div class="widget-container"> <ul>
<li>
<h3><a href="https://ecadforum.com/2018/11/19/esat-latest-ethiopian-news-60-minutes-november-19-2018/">ESAT Latest Ethiopian News (60 Minutes) November 19, 2018</a></h3>
<span class="date"><span class="tie-date">November 19, 2018</span></span>
</li>
<li>
<h3><a href="https://ecadforum.com/2018/11/18/the-women-smashing-ethiopias-glass-ceiling/">The women smashing Ethiopia&#8217;s glass ceiling</a></h3>
<span class="date"><span class="tie-date">November 18, 2018</span></span>
</li>
<li>
<h3><a href="https://ecadforum.com/2018/11/16/ethiopia-issues-arrest-warrant-for-fugitive-ex-spy-chief-over-alleged-human-rights-abuses/">Ethiopia issues arrest warrant for fugitive ex-spy chief over alleged human rights abuses</a></h3>
<span class="date"><span class="tie-date">November 16, 2018</span></span>
</li>
<li>
<h3><a href="https://ecadforum.com/2018/11/16/reverse-ethiopias-institutional-void-and-hold-tplf-accountability/">Reverse Ethiopia’s Institutional Void, and Hold TPLF Accountability</a></h3>
<span class="date"><span class="tie-date">November 16, 2018</span></span>
</li>
<li>
<h3><a href="https://ecadforum.com/2018/11/15/confronting-the-past-time-catches-up-with-eprdf-dictatorship-and-mafia-group-in-ethiopia/">Confronting the past: Time Catches Up With “EPRDF Dictatorship and Mafia Group” in Ethiopia</a></h3>
<span class="date"><span class="tie-date">November 15, 2018</span></span>
</li>
<li>
<h3><a href="https://ecadforum.com/2018/11/15/esat-latest-ethiopian-news-november-15-2018/">ESAT Latest Ethiopian News November 15, 2018</a></h3>
<span class="date"><span class="tie-date">November 15, 2018</span></span>
</li>
</ul>
<div class="clear"></div>
</div></div> <div id="ads160_600-widget-2" class="ads160-600">
<div class="ad-cell">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-4379286819423322" data-ad-slot="9207080002"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
</div>
</aside>
</div> 
<aside class="sidebar">
<div class="search-widget">
<form method="get" id="searchform-widget" action="https://ecadforum.com/">
<input type="text" id="s" name="s" value="to search type and hit enter" onfocus="if (this.value == 'to search type and hit enter') {this.value = '';}" onblur="if (this.value == '') {this.value = 'to search type and hit enter';}" />
</form>
</div>
<div id="custom_html-3" class="widget_text widget widget_custom_html"><div class="widget-top"><h4> </h4><div class="stripe-line"></div></div>
<div class="widget-container"><div class="textwidget custom-html-widget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-4379286819423322" data-ad-slot="9207080002"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div></div><div id="top-posts-2" class="widget widget_top-posts"><div class="widget-top"><h4>Top Posts</h4><div class="stripe-line"></div></div>
<div class="widget-container"><ul class='widgets-list-layout no-grav'>
<li>
<a href="https://ecadforum.com/2018/11/16/ethiopia-issues-arrest-warrant-for-fugitive-ex-spy-chief-over-alleged-human-rights-abuses/" title="Ethiopia issues arrest warrant for fugitive ex-spy chief over alleged human rights abuses" class="bump-view" data-bump-view="tp">
<img width="40" height="40" src="https://i2.wp.com/ecadforum.com/wp-content/uploads/2018/11/Getachew-Assefa.jpg?resize=40%2C40&#038;ssl=1" class='widgets-list-layout-blavatar' alt="Ethiopia issues arrest warrant for fugitive ex-spy chief over alleged human rights abuses" data-pin-nopin="true" />
</a>
<div class="widgets-list-layout-links">
<a href="https://ecadforum.com/2018/11/16/ethiopia-issues-arrest-warrant-for-fugitive-ex-spy-chief-over-alleged-human-rights-abuses/" class="bump-view" data-bump-view="tp">
Ethiopia issues arrest warrant for fugitive ex-spy chief over alleged human rights abuses </a>
</div>
</li>
<li>
<a href="https://ecadforum.com/2018/11/18/the-women-smashing-ethiopias-glass-ceiling/" title="The women smashing Ethiopia&#039;s glass ceiling" class="bump-view" data-bump-view="tp">
<img width="40" height="40" src="https://i2.wp.com/ecadforum.com/wp-content/uploads/2018/11/Lawyer-Meaza-Ashenafi.jpg?resize=40%2C40&#038;ssl=1" class='widgets-list-layout-blavatar' alt="The women smashing Ethiopia&#039;s glass ceiling" data-pin-nopin="true" />
</a>
<div class="widgets-list-layout-links">
<a href="https://ecadforum.com/2018/11/18/the-women-smashing-ethiopias-glass-ceiling/" class="bump-view" data-bump-view="tp">
The women smashing Ethiopia&#039;s glass ceiling </a>
</div>
</li>
<li>
<a href="https://ecadforum.com/2018/11/15/esat-latest-ethiopian-news-november-15-2018/" title="ESAT Latest Ethiopian News November 15, 2018" class="bump-view" data-bump-view="tp">
<img width="40" height="40" src="https://i0.wp.com/ecadforum.com/wp-content/uploads/2018/11/ESAT-News-November-15-2018.jpg?resize=40%2C40&#038;ssl=1" class='widgets-list-layout-blavatar' alt="ESAT Latest Ethiopian News November 15, 2018" data-pin-nopin="true" />
</a>
<div class="widgets-list-layout-links">
<a href="https://ecadforum.com/2018/11/15/esat-latest-ethiopian-news-november-15-2018/" class="bump-view" data-bump-view="tp">
ESAT Latest Ethiopian News November 15, 2018 </a>
</div>
</li>
<li>
<a href="https://ecadforum.com/2018/11/16/reverse-ethiopias-institutional-void-and-hold-tplf-accountability/" title="Reverse Ethiopia’s Institutional Void, and Hold TPLF Accountability" class="bump-view" data-bump-view="tp">
<img width="40" height="40" src="https://i0.wp.com/ecadforum.com/wp-content/uploads/2018/11/Addis-Ababa-Ethiopia.jpg?resize=40%2C40&#038;ssl=1" class='widgets-list-layout-blavatar' alt="Reverse Ethiopia’s Institutional Void, and Hold TPLF Accountability" data-pin-nopin="true" />
</a>
<div class="widgets-list-layout-links">
<a href="https://ecadforum.com/2018/11/16/reverse-ethiopias-institutional-void-and-hold-tplf-accountability/" class="bump-view" data-bump-view="tp">
Reverse Ethiopia’s Institutional Void, and Hold TPLF Accountability </a>
</div>
</li>
<li>
<a href="https://ecadforum.com/2018/11/15/ethiopia-arrests-former-deputy-spy-chief-yared-zerihun/" title="Ethiopia arrests former deputy spy chief Yared Zerihun" class="bump-view" data-bump-view="tp">
<img width="40" height="40" src="https://i0.wp.com/ecadforum.com/wp-content/uploads/2018/11/Yared-Zerihun-arrested.jpg?resize=40%2C40&#038;ssl=1" class='widgets-list-layout-blavatar' alt="Ethiopia arrests former deputy spy chief Yared Zerihun" data-pin-nopin="true" />
</a>
<div class="widgets-list-layout-links">
<a href="https://ecadforum.com/2018/11/15/ethiopia-arrests-former-deputy-spy-chief-yared-zerihun/" class="bump-view" data-bump-view="tp">
Ethiopia arrests former deputy spy chief Yared Zerihun </a>
</div>
</li>
<li>
<a href="https://ecadforum.com/2018/11/15/confronting-the-past-time-catches-up-with-eprdf-dictatorship-and-mafia-group-in-ethiopia/" title="Confronting the past: Time Catches Up With “EPRDF Dictatorship and Mafia Group” in Ethiopia" class="bump-view" data-bump-view="tp">
<img width="40" height="40" src="https://i2.wp.com/ecadforum.com/wp-content/uploads/2018/11/Kinfe-Dagnew-arrested.jpg?resize=40%2C40&#038;ssl=1" class='widgets-list-layout-blavatar' alt="Confronting the past: Time Catches Up With “EPRDF Dictatorship and Mafia Group” in Ethiopia" data-pin-nopin="true" />
</a>
<div class="widgets-list-layout-links">
<a href="https://ecadforum.com/2018/11/15/confronting-the-past-time-catches-up-with-eprdf-dictatorship-and-mafia-group-in-ethiopia/" class="bump-view" data-bump-view="tp">
Confronting the past: Time Catches Up With “EPRDF Dictatorship and Mafia Group” in Ethiopia </a>
</div>
</li>
<li>
<a href="https://ecadforum.com/2018/11/19/esat-latest-ethiopian-news-60-minutes-november-19-2018/" title="ESAT Latest Ethiopian News (60 Minutes) November 19, 2018" class="bump-view" data-bump-view="tp">
<img width="40" height="40" src="https://i0.wp.com/ecadforum.com/wp-content/uploads/2018/11/ESAT-News-November-19-2018.jpg?resize=40%2C40&#038;ssl=1" class='widgets-list-layout-blavatar' alt="ESAT Latest Ethiopian News (60 Minutes) November 19, 2018" data-pin-nopin="true" />
</a>
<div class="widgets-list-layout-links">
<a href="https://ecadforum.com/2018/11/19/esat-latest-ethiopian-news-60-minutes-november-19-2018/" class="bump-view" data-bump-view="tp">
ESAT Latest Ethiopian News (60 Minutes) November 19, 2018 </a>
</div>
 </li>
<li>
<a href="https://ecadforum.com/2012/03/20/the-case-of-alleged-fraud-and-corruption-at-ethiopia-commodity-exchange/" title="The case of alleged fraud and corruption at Ethiopia Commodity Exchange" class="bump-view" data-bump-view="tp">
<img width="40" height="40" src="https://i1.wp.com/ecadforum.com/wp-content/uploads/2012/03/Eleni-Gabre-Madhin.jpg?resize=40%2C40&#038;ssl=1" class='widgets-list-layout-blavatar' alt="The case of alleged fraud and corruption at Ethiopia Commodity Exchange" data-pin-nopin="true" />
</a>
<div class="widgets-list-layout-links">
<a href="https://ecadforum.com/2012/03/20/the-case-of-alleged-fraud-and-corruption-at-ethiopia-commodity-exchange/" class="bump-view" data-bump-view="tp">
The case of alleged fraud and corruption at Ethiopia Commodity Exchange </a>
</div>
</li>
<li>
<a href="https://ecadforum.com/2018/11/13/esat-latest-ethiopian-news-november-13-2018/" title="ESAT Latest Ethiopian News November 13, 2018" class="bump-view" data-bump-view="tp">
<img width="40" height="40" src="https://i1.wp.com/ecadforum.com/wp-content/uploads/2018/11/ESAT-News-Kinfe-Dagnew.jpg?resize=40%2C40&#038;ssl=1" class='widgets-list-layout-blavatar' alt="ESAT Latest Ethiopian News November 13, 2018" data-pin-nopin="true" />
</a>
<div class="widgets-list-layout-links">
<a href="https://ecadforum.com/2018/11/13/esat-latest-ethiopian-news-november-13-2018/" class="bump-view" data-bump-view="tp">
ESAT Latest Ethiopian News November 13, 2018 </a>
</div>
</li>
</ul>
</div></div><div id="custom_html-5" class="widget_text widget widget_custom_html"><div class="widget-top"><h4> </h4><div class="stripe-line"></div></div>
<div class="widget-container"><div class="textwidget custom-html-widget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-4379286819423322" data-ad-slot="7930606409" data-matched-content-ui-type="image_stacked" data-matched-content-rows-num="5" data-matched-content-columns-num="1" data-ad-format="autorelaxed"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div></div><div id="eu_cookie_law_widget-2" class="widget widget_eu_cookie_law_widget"><div class="hide-on-time negative" data-hide-timeout="30" data-consent-expiration="180" id="eu-cookie-law">
<form method="post">
<input type="submit" value="Close and accept" class="accept" />
</form>
Privacy &amp; Cookies: This site uses cookies. By continuing to use this website, you agree to their use. <br />
To find out more, including how to control cookies, see here:
<a href="https://automattic.com/cookies/">
Cookie Policy	</a>
</div>
</div></div></aside>
<div class="clear"></div> <div class="clear"></div>
</div>
</div>
<footer id="theme-footer" class="fade-in animated4">
<div id="footer-widget-area" class="footer-1c container">
<div id="footer-first" class="footer-widgets-box">
<div id="text-html-widget-8" class="text-html-box">
The views, opinions and positions expressed on ECADF Ethiopian News are the opinions of individual contributors and may not necessarily reflect the views of our website. </div>
</div>
</div>
<div class="clear"></div>
</footer>
<div class="clear"></div>
<div class="footer-bottom fade-in animated4">
<div class="container">
<div class="alignleft">
          © Copyright 2018, All Rights Reserved. | <strong><a href="https://ecadforum.com/" target="_blank" rel="nofollow noopener">ECADF Ethiopian News</a></strong>                                            <strong><a href="https://ecadforum.com/" target="_blank" rel="nofollow noopener">Home</a> |  <a href="https://ecadforum.com/Amharic/" target="_blank" rel="nofollow noopener">Amharic</a> |  <a href="https://ecadforum.com/category/video/" target="_blank" rel="nofollow noopener">Video</a> |  <a href="https://ecadforum.com/voa-amharic-radio-daily-broadcast-to-ethiopia/" target="_blank" rel="nofollow noopener">VOA</a>  |  <a href="https://ecadforum.com/contact-2/">Contact Us</a></strong> </div>
</div>
</div>
</div>
<div id="topcontrol" class="tieicon-up-open" title="Scroll To Top"></div>
<div id="fb-root"></div>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var tie = {"go_to":"Go to...","ajaxurl":"https:\/\/ecadforum.com\/wp-admin\/admin-ajax.php","your_rating":"Your Rating:","is_singular":"1","reading_indicator":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://ecadforum.com/wp-content/themes/jarida/js/tie-scripts.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/6.7/_inc/build/widgets/eu-cookie-law/eu-cookie-law.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/6.7/modules/likes/queuehandler.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/4.9.8/wp-includes/js/comment-reply.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/4.9.8/wp-includes/js/wp-embed.min.js'></script>
<script async="async" type='text/javascript' src='https://ecadforum.com/wp-content/plugins/akismet/_inc/form.js'></script>

<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=787806777997466&version=v2.3";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>
<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=21932601&postid=44017&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=https%3A%2F%2Fecadforum.com%2Fwp-content%2Fuploads%2F2015%2F11%2FECADF_Gravatar.png&greeting=Comments+%E2%80%94+What+do+you+think%3F&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=6.7&show_cookie_consent=10&has_cookie_consent=0&sig=ed0690fcda09d1a7bd0b96f2075c5bebbf8c7e5d#parent=https%3A%2F%2Fecadforum.com%2F2018%2F11%2F15%2Fconfronting-the-past-time-catches-up-with-eprdf-dictatorship-and-mafia-group-in-ethiopia%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=21932601&postid=44017&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=https%3A%2F%2Fecadforum.com%2Fwp-content%2Fuploads%2F2015%2F11%2FECADF_Gravatar.png&greeting=Comments+%E2%80%94+What+do+you+think%3F&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=6.7&show_cookie_consent=10&has_cookie_consent=0&sig=ed0690fcda09d1a7bd0b96f2075c5bebbf8c7e5d#parent=https%3A%2F%2Fecadforum.com%2F2018%2F11%2F15%2Fconfronting-the-past-time-catches-up-with-eprdf-dictatorship-and-mafia-group-in-ethiopia%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>
<script type='text/javascript' src='https://stats.wp.com/e-201847.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:6.7',blog:'21932601',post:'44017',tz:'-8',srv:'ecadforum.com'} ]);
	_stq.push([ 'clickTrackerInit', '21932601', '44017' ]);
</script>
</body>
</html>
