<!DOCTYPE html>
<link rel="alternate" href="https://ecadforum.com/" hreflang="en-us" />
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
<meta charset="UTF-8" />
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="pingback" href="https://ecadforum.com/xmlrpc.php" />
<title>ESAT Latest Ethiopian News May 21, 2018</title>

<meta property="og:type" content="article" />
<meta property="og:title" content="ESAT Latest Ethiopian News May 21, 2018" />
<meta property="og:description" content="Ethiopian Satellite Television and Radio (ESAT) latest Ethiopian News from Amsterdam and Washington DC, May 21, 2018." />
<meta property="og:image" content="https://ecadforum.com/wp-content/uploads/2018/05/ESAT-News-May-21-2018.jpg" />
<meta property="og:url" content="https://ecadforum.com/2018/05/21/esat-latest-ethiopian-news-may-21-2018/" />
<meta property="og:site_name" content="ECADF Ethiopian News" />
<meta property="article:publisher" content="https://www.facebook.com/ethiopianews" />
<meta property="article:published_time" content="2018-05-21T10:36:56+00:00" />
<meta property="article:modified_time" content="2018-05-21T10:36:56+00:00" />
<meta property="og:updated_time" content="2018-05-21T10:36:56+00:00" />


<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:title" content="ESAT Latest Ethiopian News May 21, 2018">
<meta name="twitter:description" content="Ethiopian Satellite Television and Radio (ESAT) latest Ethiopian News from Amsterdam and Washington DC, May 21, 2018.">
<meta name="twitter:image" content="https://ecadforum.com/wp-content/uploads/2018/05/ESAT-News-May-21-2018.jpg">
<meta name="twitter:site" content="@ecadf">
<meta name="twitter:creator" content="@ecadf">



<link rel="author" href="https://plus.google.com/u/0/+EcadfEthiopiaNews/posts" />
<meta name="description" content="Ethiopian Satellite Television and Radio (ESAT) latest Ethiopian News from Amsterdam and Washington DC, May 21, 2018." />
<meta name="keywords" content="esat,ethiopia,ethiopian news,news" />
<meta name="robots" content="index,nofollow" />
<link rel="canonical" href="https://ecadforum.com/2018/05/21/esat-latest-ethiopian-news-may-21-2018/" />
<script type="text/javascript">
				window.ga=window.ga||function(){(ga.q=ga.q||[]).push(arguments)};ga.l=+new Date;
				ga('create', 'UA-9883609-1', { 'cookieDomain': 'ecadforum.com' } );
				// Plugins
				ga('require', 'ec');ga('require', 'linkid', 'linkid.js');ga('set', 'anonymizeIp', true);ga('require', 'outboundLinkTracker');ga('require', 'outboundFormTracker');ga('require', 'eventTracker');ga('require', 'urlChangeTracker');ga('require', 'pageVisibilityTracker');ga('require', 'mediaQueryTracker');ga('require', 'impressionTracker');ga('require', 'maxScrollTracker');ga('require', 'socialWidgetTracker');ga('require', 'cleanUrlTracker');
				ga('send', 'pageview');
			</script>
<script async src="https://www.google-analytics.com/analytics.js"></script>
<script async src="https://ecadforum.com/wp-content/plugins/all-in-one-seo-pack-pro/public/js/vendor/autotrack.x28145.js"></script>

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="ECADF Ethiopian News &raquo; Feed" href="https://ecadforum.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="ECADF Ethiopian News &raquo; Comments Feed" href="https://ecadforum.com/comments/feed/" />
<script>
var MP3jPLAYLISTS = [];
var MP3jPLAYERS = [];
</script>
<link rel="alternate" type="application/rss+xml" title="ECADF Ethiopian News &raquo; ESAT Latest Ethiopian News May 21, 2018 Comments Feed" href="https://ecadforum.com/2018/05/21/esat-latest-ethiopian-news-may-21-2018/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/ecadforum.com\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='mashsb-styles-css' href='https://ecadforum.com/wp-content/plugins/mashsharer/assets/css/mashsb.min.x28145.css' type='text/css' media='all' />
<style id='mashsb-styles-inline-css' type='text/css'>
.mashsb-count {color:#9a9b9c;}
        [class^="mashicon-"], .onoffswitch-label, .onoffswitch2-label, .onoffswitch {
            border-radius: 2px;
        }@media only screen and (min-width:568px){.mashsb-buttons a {min-width: 177px;}}
</style>
<link rel='stylesheet' id='tie-style-css' href='https://ecadforum.com/wp-content/themes/jarida/style.x28145.css' type='text/css' media='all' />
<link rel='stylesheet' id='Roboto+Condensed-css' href='https://fonts.googleapis.com/css?family=Roboto+Condensed%3A300%2C300italic%2Cregular%2Citalic%2C700%2C700italic' type='text/css' media='all' />
<link rel='stylesheet' id='Oswald-css' href='https://fonts.googleapis.com/css?family=Oswald%3Aregular%2C700' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack-widget-social-icons-styles-css' href='https://ecadforum.com/wp-content/plugins/jetpack/modules/widgets/social-icons/social-icons.x28145.css' type='text/css' media='all' />
<link rel='stylesheet' id='__EPYT__style-css' href='https://ecadforum.com/wp-content/plugins/youtube-embed-plus/styles/ytprefs.min.x28145.css' type='text/css' media='all' />
<style id='__EPYT__style-inline-css' type='text/css'>

                .epyt-gallery-thumb {
                        width: 33.333%;
                }
                
</style>
<link rel='stylesheet' id='mp3-jplayer-css' href='https://ecadforum.com/wp-content/plugins/mp3-jplayer/css/dark.x28145.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://ecadforum.com/wp-content/plugins/jetpack/css/jetpack.x28145.css' type='text/css' media='all' />
<script type='text/javascript' src='https://ecadforum.com/wp-includes/js/jquery/jquery.x28145.js'></script>
<script type='text/javascript' src='https://ecadforum.com/wp-includes/js/jquery/jquery-migrate.min.x28145.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mashsb = {"shares":"266","round_shares":"1","animate_shares":"0","dynamic_buttons":"0","share_url":"https:\/\/ecadforum.com\/2018\/05\/21\/esat-latest-ethiopian-news-may-21-2018\/","title":"ESAT+Latest+Ethiopian+News+May+21%2C+2018","image":"https:\/\/ecadforum.com\/wp-content\/uploads\/2018\/05\/ESAT-News-May-21-2018.jpg","desc":"Ethiopian Satellite Television and Radio (ESAT) latest Ethiopian News from Amsterdam and Washington DC, May 21, 2018.","hashtag":"ecadf","subscribe":"content","subscribe_url":"","activestatus":"1","singular":"1","twitter_popup":"1","refresh":"1","nonce":"3ec2e15b1d","postid":"41387","servertime":"1526924234","ajaxurl":"https:\/\/ecadforum.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://ecadforum.com/wp-content/plugins/mashsharer/assets/js/mashsb.min.x28145.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _EPYT_ = {"ajaxurl":"https:\/\/ecadforum.com\/wp-admin\/admin-ajax.php","security":"da7cb50e75","gallery_scrolloffset":"20","eppathtoscripts":"https:\/\/ecadforum.com\/wp-content\/plugins\/youtube-embed-plus\/scripts\/","epresponsiveselector":"[\"iframe.__youtube_prefs_widget__\"]","epdovol":"1","version":"11.8.7","evselector":"iframe.__youtube_prefs__[src], iframe[src*=\"youtube.com\/embed\/\"], iframe[src*=\"youtube-nocookie.com\/embed\/\"]","ajax_compat":"","ytapi_load":"light","stopMobileBuffer":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://ecadforum.com/wp-content/plugins/youtube-embed-plus/scripts/ytprefs.min.x28145.js'></script>
<link rel='https://api.w.org/' href='https://ecadforum.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://ecadforum.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://ecadforum.com/wp-includes/wlwmanifest.xml" />
<link rel='prev' title='Memorandum No. 6: PM Abiy Preaching “Walk the Talk in Faith”!' href='https://ecadforum.com/2018/05/20/memorandum-no-6-pm-abiy-preaching-walk-the-talk-in-faith/' />
<meta name="generator" content="WordPress 4.9.6" />
<link rel='shortlink' href='https://wp.me/p1u1FD-aLx' />
<link rel="alternate" type="application/json+oembed" href="https://ecadforum.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fecadforum.com%2F2018%2F05%2F21%2Fesat-latest-ethiopian-news-may-21-2018%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://ecadforum.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fecadforum.com%2F2018%2F05%2F21%2Fesat-latest-ethiopian-news-may-21-2018%2F&#038;format=xml" />
<meta property="fb:app_id" content="787806777997466" />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<link rel="shortcut icon" href="https://ecadforum.com/wp-content/uploads/2015/10/ECADF-iPad-Icon.x28145.png" title="Favicon" /><!--[if IE]>
<script type="text/javascript">jQuery(document).ready(function (){ jQuery(".menu-item").has("ul").children("a").attr("aria-haspopup", "true");});</script>
<![endif]-->
<!--[if lt IE 9]>
<script src="https://ecadforum.com/wp-content/themes/jarida/js/html5.x28145.js"></script>
<script src="https://ecadforum.com/wp-content/themes/jarida/js/selectivizr-min.x28145.js"></script>
<![endif]-->
<!--[if IE 8]>
<link rel="stylesheet" type="text/css" media="all" href="https://ecadforum.com/wp-content/themes/jarida/css/ie8.x28145.css" />
<![endif]-->
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1" />
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1, user-scalable=no" />
<style type="text/css" media="screen">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</style>
<link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://ecadforum.com/wp-content/uploads/2015/10/ECADF-iPad-Retina-Icon.x28145.png" />
<link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://ecadforum.com/wp-content/uploads/2015/10/ECADF-iPhone-Retina-Icon.x28145.png" />
<link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://ecadforum.com/wp-content/uploads/2015/10/ECADF-iPad-Icon1.x28145.png" />
<link rel="apple-touch-icon-precomposed" href="https://ecadforum.com/wp-content/uploads/2015/10/ECADF-iPhone-Icon.x28145.png" />
<style type="text/css">.broken_link, a.broken_link {
	text-decoration: line-through;
}</style> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-4379286819423322",
          enable_page_level_ads: true
     });
</script>
</head>
<body id="top" class="post-template-default single single-post postid-41387 single-format-standard">
<div class="background-cover"></div>
<div class="wrapper">
<div class="container">
<header id="theme-header">
<div class="header-content fade-in animated1">
<div class="logo">
<h2> <a title="ECADF Ethiopian News" href="https://ecadforum.com/">
<img src="https://ecadforum.com/wp-content/uploads/2017/08/ecadf-logo-2017.x28145.png" alt="ECADF Ethiopian News" /><strong>ECADF Ethiopian News Ethiopian news, video and opinions</strong>
</a>
</h2> </div>
<div class="clear"></div>
</div>
<nav id="main-nav" class="fade-in animated2">
<div class="container">
<div class="main-menu"><ul id="menu-category" class="menu"><li id="menu-item-601" class="menu-item  menu-item-type-custom  menu-item-object-custom  menu-item-home"><a href="https://ecadforum.com">Home</a></li>
<li id="menu-item-7476" class="menu-item  menu-item-type-custom  menu-item-object-custom"><a href="https://www.ecadforum.com/Amharic/">Amharic</a></li>
<li id="menu-item-26255" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="https://ecadforum.com/category/video/">Video</a></li>
<li id="menu-item-37780" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="https://ecadforum.com/category/ethiopianmusic/">Music Video</a></li>
<li id="menu-item-14642" class="menu-item  menu-item-type-custom  menu-item-object-custom"><a title="VOA Amharic radio" href="https://ecadforum.com/voa-amharic-radio-daily-broadcast-to-ethiopia/">VOA</a></li>
<li id="menu-item-26052" class="menu-item  menu-item-type-custom  menu-item-object-custom  menu-item-has-children"><a>Categories</a>
<ul class="sub-menu">
<li id="menu-item-26047" class="menu-item  menu-item-type-taxonomy  menu-item-object-category  current-post-ancestor  current-menu-parent  current-post-parent"><a href="https://ecadforum.com/category/news/">News</a></li>
<li id="menu-item-26049" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a rel="nofollow" href="https://ecadforum.com/category/video/">Video</a></li>
<li id="menu-item-37782" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a rel="nofollow" href="https://ecadforum.com/category/ethiopianmusic/">Music Video</a></li>
<li id="menu-item-26048" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="https://ecadforum.com/category/opinion/">Opinions</a></li>
<li id="menu-item-26050" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="https://ecadforum.com/category/events/">Events</a></li>
<li id="menu-item-26051" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="https://ecadforum.com/category/sport/">Sport</a></li>
</ul> 
</li>
<li id="menu-item-28217" class="menu-item  menu-item-type-custom  menu-item-object-custom  menu-item-has-children"><a>Social media</a>
<ul class="sub-menu">
<li id="menu-item-25967" class="menu-item  menu-item-type-custom  menu-item-object-custom"><a rel="nofollow" href="https://www.facebook.com/ethiopianews" target="_blank">Facebook</a></li>
<li id="menu-item-25968" class="menu-item  menu-item-type-custom  menu-item-object-custom"><a rel="nofollow" href="https://twitter.com/ECADF" target="_blank">Twitter</a></li>
<li id="menu-item-25969" class="menu-item  menu-item-type-custom  menu-item-object-custom"><a rel="nofollow" href="https://www.youtube.com/user/ecadfethiopia/videos" target="_blank">YouTube</a></li>
<li id="menu-item-7006" class="menu-item  menu-item-type-custom  menu-item-object-custom"><a title="nofollow" href="https://ecadforum.com/ecadf-chat-room/">Paltalk</a></li>
</ul> 
</li>
<li id="menu-item-38672" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="https://ecadforum.com/archive/">Archive</a></li>
<li id="menu-item-26010" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a rel="nofollow" href="https://ecadforum.com/contact-2/">Contact Us</a></li>
</ul></div> </div>
</nav>
</header>
<div id="main-content" class="container fade-in animated3 sidebar-narrow-left">
<div class="content-wrap">
<div class="content">
<article id="the-post" class="post-listing post-41387 post type-post status-publish format-standard has-post-thumbnail hentry category-news tag-esat tag-ethiopia tag-ethiopian-news">
<div class="post-inner">
<h1 class="name post-title entry-title" itemprop="itemReviewed" itemscope itemtype="http://schema.org/Thing"><span itemprop="name">ESAT Latest Ethiopian News May 21, 2018</span></h1>
<p class="post-meta">
<span class="post-meta-author">Posted by: <a href="https://ecadforum.com/author/ecadforum/" title="">ecadforum </a></span>
<span class="post-cats">in <a href="https://ecadforum.com/category/news/" rel="category tag">News</a></span>
<span class="tie-date">May 21, 2018</span>
</p>
<div class="clear"></div>
<div style="float:none;margin:0px 0 0px 0;text-align:center;">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-4379286819423322" data-ad-slot="5792721206"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<div class="entry">
<aside class="mashsb-container mashsb-main mashsb-stretched">
<div class="mashsb-box">
<div class="mashsb-count mash-large" style="float:left;">
<div class="counts mashsbcount">266</div>
<p><span class="mashsb-sharetext">SHARES</span></div>
<div class="mashsb-buttons"><a class="mashicon-facebook mash-large mash-center mashsb-noshadow" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fecadforum.com%2F2018%2F05%2F21%2Fesat-latest-ethiopian-news-may-21-2018%2F" target="_blank" rel="noopener nofollow"><span class="icon"></span><span class="text">Share</span></a><a class="mashicon-twitter mash-large mash-center mashsb-noshadow" href="https://twitter.com/intent/tweet?text=ESAT%20Latest%20Ethiopian%20News%20May%2021%2C%202018&#038;url=https://wp.me/p1u1FD-aLx&#038;via=ecadf" target="_blank" rel="noopener nofollow"><span class="icon"></span><span class="text">Tweet</span></a></p>
<div class="onoffswitch2 mash-large mashsb-noshadow" style="display:none;"></div>
</div></div>
<div style="clear:both;"></div>
<div class="mashsb-toggle-container"></div>
</aside>
<p> <iframe width="640" height="360" src="https://www.youtube.com/embed/iHhhWmk20kA" frameborder="0" allow="autoplay; encrypted-media" allowfullscreen></iframe></p>
<p>Ethiopian Satellite Television and Radio (ESAT) latest Ethiopian News from Amsterdam and Washington DC, May 21, 2018.</p>
<div class="fb-comments" data-href="https://ecadforum.com/2018/05/21/esat-latest-ethiopian-news-may-21-2018/" data-numposts="10" data-width="" data-colorscheme="light"></div>
</div>
<span style="display:none"><a href="https://ecadforum.com/tag/esat/" rel="tag">ESAT</a> <a href="https://ecadforum.com/tag/ethiopia/" rel="tag">Ethiopia</a> <a href="https://ecadforum.com/tag/ethiopian-news/" rel="tag">Ethiopian News</a></span> <span style="display:none" class="updated">2018-05-21</span>
<div style="display:none" class="vcard author" itemprop="author" itemscope itemtype="http://schema.org/Person"><strong class="fn" itemprop="name"><a href="https://plus.google.com/u/0/b/113621583050101745316/+Ecadforumethiopia/posts?rel=author">+ecadforum</a></strong></div>
</div>
</article>
<div id="comments">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2018/05/21/esat-latest-ethiopian-news-may-21-2018/#respond" style="display:none;">Cancel reply</a></small>
</h3>
<form id="commentform" class="comment-form">
<iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=21932601&#038;postid=41387&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=mystery&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=transparent&#038;lang=en_US&#038;jetpack_version=6.1&#038;sig=598a19b4389b9539c9859468a44209706fbf23ab#parent=https%3A%2F%2Fecadforum.com%2F2018%2F05%2F21%2Fesat-latest-ethiopian-news-may-21-2018%2F" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment"></iframe>
<!--[if !IE]><!-->
<script>
					document.addEventListener('DOMContentLoaded', function () {
						var commentForms = document.getElementsByClassName('jetpack_remote_comment');
						for (var i = 0; i < commentForms.length; i++) {
							commentForms[i].allowTransparency = true;
							commentForms[i].scrolling = 'no';
						}
					});
				</script>
<!--<![endif]-->
</form>
</div>
<input type="hidden" name="comment_parent" id="comment_parent" value="" />
</div>
<section id="related_posts">
<div class="block-head">
<h3>Related Posts</h3><div class="stripe-line"></div>
</div>
<div class="post-listing">
<div class="related-item">
<div class="post-thumbnail">
<a href="https://ecadforum.com/2018/05/20/memorandum-no-6-pm-abiy-preaching-walk-the-talk-in-faith/" title="Permalink to Memorandum No. 6: PM Abiy Preaching “Walk the Talk in Faith”!" rel="bookmark">
<img width="300" height="160" src="https://ecadforum.com/wp-content/plugins/jetpack/modules/lazy-images/images/1x1.trans.x28145.gif" class="attachment-tie-large size-tie-large wp-post-image" alt="PM Abiy Preaching “Walk the Talk in Faith”!" data-lazy-src="https://i2.wp.com/ecadforum.com/wp-content/uploads/2018/05/walk-the-talk.jpg?resize=300%2C160&amp;ssl=1" data-lazy-srcset="https://i2.wp.com/ecadforum.com/wp-content/uploads/2018/05/walk-the-talk.jpg?w=620&amp;ssl=1 620w, https://i2.wp.com/ecadforum.com/wp-content/uploads/2018/05/walk-the-talk.jpg?resize=150%2C80&amp;ssl=1 150w, https://i2.wp.com/ecadforum.com/wp-content/uploads/2018/05/walk-the-talk.jpg?resize=300%2C160&amp;ssl=1 300w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" /> </a>
</div>
<h3><a href="https://ecadforum.com/2018/05/20/memorandum-no-6-pm-abiy-preaching-walk-the-talk-in-faith/" title="Permalink to Memorandum No. 6: PM Abiy Preaching “Walk the Talk in Faith”!" rel="bookmark">Memorandum No. 6: PM Abiy Preaching “Walk the Talk in Faith”!</a></h3>
<p class="post-meta"><span class="tie-date">May 20, 2018</span></p>
</div>
<div class="related-item">
<div class="post-thumbnail">
<a href="https://ecadforum.com/2018/05/20/uncertainty-strains-ethiopian-refugees-in-a-kenya-camp/" title="Permalink to Uncertainty Strains Ethiopian Refugees in a Kenya Camp" rel="bookmark">
<img width="300" height="160" src="https://ecadforum.com/wp-content/plugins/jetpack/modules/lazy-images/images/1x1.trans.x28145.gif" class="attachment-tie-large size-tie-large wp-post-image" alt="Machi, an Ethiopian refugee in Kenya&#039;s Dambala Fachana camp." data-lazy-src="https://i0.wp.com/ecadforum.com/wp-content/uploads/2018/05/Ethiopian-refugee-in-Kenya1.jpg?resize=300%2C160&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/ecadforum.com/wp-content/uploads/2018/05/Ethiopian-refugee-in-Kenya1.jpg?w=620&amp;ssl=1 620w, https://i0.wp.com/ecadforum.com/wp-content/uploads/2018/05/Ethiopian-refugee-in-Kenya1.jpg?resize=150%2C80&amp;ssl=1 150w, https://i0.wp.com/ecadforum.com/wp-content/uploads/2018/05/Ethiopian-refugee-in-Kenya1.jpg?resize=300%2C160&amp;ssl=1 300w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" /> </a>
</div>
<h3><a href="https://ecadforum.com/2018/05/20/uncertainty-strains-ethiopian-refugees-in-a-kenya-camp/" title="Permalink to Uncertainty Strains Ethiopian Refugees in a Kenya Camp" rel="bookmark">Uncertainty Strains Ethiopian Refugees in a Kenya Camp</a></h3>
<p class="post-meta"><span class="tie-date">May 20, 2018</span></p>
</div>
<div class="related-item">
<div class="post-thumbnail">
<a href="https://ecadforum.com/2018/05/19/ethiopia-delivering-an-unborn-dream-left-to-us-by-history/" title="Permalink to Ethiopia: Delivering an unborn dream left to us by history" rel="bookmark">
<img width="300" height="160" src="https://ecadforum.com/wp-content/plugins/jetpack/modules/lazy-images/images/1x1.trans.x28145.gif" class="attachment-tie-large size-tie-large wp-post-image" alt="Ethiopian politician Andualem Aragie&#039;s opinions." data-lazy-src="https://i1.wp.com/ecadforum.com/wp-content/uploads/2018/05/Andualem-Aragie.jpg?resize=300%2C160&amp;ssl=1" data-lazy-srcset="https://i1.wp.com/ecadforum.com/wp-content/uploads/2018/05/Andualem-Aragie.jpg?w=620&amp;ssl=1 620w, https://i1.wp.com/ecadforum.com/wp-content/uploads/2018/05/Andualem-Aragie.jpg?resize=150%2C80&amp;ssl=1 150w, https://i1.wp.com/ecadforum.com/wp-content/uploads/2018/05/Andualem-Aragie.jpg?resize=300%2C160&amp;ssl=1 300w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" /> </a>
</div>
<h3><a href="https://ecadforum.com/2018/05/19/ethiopia-delivering-an-unborn-dream-left-to-us-by-history/" title="Permalink to Ethiopia: Delivering an unborn dream left to us by history" rel="bookmark">Ethiopia: Delivering an unborn dream left to us by history</a></h3>
<p class="post-meta"><span class="tie-date">May 19, 2018</span></p>
</div>
<div class="related-item">
<div class="post-thumbnail">
<a href="https://ecadforum.com/2018/05/19/real-accountability-and-the-need-to-restore-billions-of-us-dollar-to-ethiopias-poor/" title="Permalink to Real Accountability and the Need to Restore Billions of US Dollar to Ethiopia’s Poor" rel="bookmark">
<img width="300" height="160" src="https://ecadforum.com/wp-content/plugins/jetpack/modules/lazy-images/images/1x1.trans.x28145.gif" class="attachment-tie-large size-tie-large wp-post-image" alt="IMF warns Ethiopia the economy is confronted with the threats of &quot;externals imbalance&quot;." data-lazy-src="https://i0.wp.com/ecadforum.com/wp-content/uploads/2018/01/us-dollar-and-ethiopia.jpg?resize=300%2C160&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/ecadforum.com/wp-content/uploads/2018/01/us-dollar-and-ethiopia.jpg?w=620&amp;ssl=1 620w, https://i0.wp.com/ecadforum.com/wp-content/uploads/2018/01/us-dollar-and-ethiopia.jpg?resize=300%2C160&amp;ssl=1 300w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" /> </a>
</div>
<h3><a href="https://ecadforum.com/2018/05/19/real-accountability-and-the-need-to-restore-billions-of-us-dollar-to-ethiopias-poor/" title="Permalink to Real Accountability and the Need to Restore Billions of US Dollar to Ethiopia’s Poor" rel="bookmark">Real Accountability and the Need to Restore Billions of US Dollar to Ethiopia’s Poor</a></h3>
<p class="post-meta"><span class="tie-date">May 19, 2018</span></p>
</div>
<div class="related-item">
<div class="post-thumbnail">
<a href="https://ecadforum.com/2018/05/19/esat-latest-ethiopian-news-may-19-2018/" title="Permalink to ESAT Latest Ethiopian News May 19, 2018" rel="bookmark">
<img width="300" height="160" src="https://ecadforum.com/wp-content/plugins/jetpack/modules/lazy-images/images/1x1.trans.x28145.gif" class="attachment-tie-large size-tie-large wp-post-image" alt="ESAT Latest Ethiopian News May 19, 2018." data-lazy-src="https://i2.wp.com/ecadforum.com/wp-content/uploads/2018/05/ESAT-News-May-19-2018.jpg?resize=300%2C160&amp;ssl=1" data-lazy-srcset="https://i2.wp.com/ecadforum.com/wp-content/uploads/2018/05/ESAT-News-May-19-2018.jpg?w=620&amp;ssl=1 620w, https://i2.wp.com/ecadforum.com/wp-content/uploads/2018/05/ESAT-News-May-19-2018.jpg?resize=150%2C80&amp;ssl=1 150w, https://i2.wp.com/ecadforum.com/wp-content/uploads/2018/05/ESAT-News-May-19-2018.jpg?resize=300%2C160&amp;ssl=1 300w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" /> </a>
</div>
<h3><a href="https://ecadforum.com/2018/05/19/esat-latest-ethiopian-news-may-19-2018/" title="Permalink to ESAT Latest Ethiopian News May 19, 2018" rel="bookmark">ESAT Latest Ethiopian News May 19, 2018</a></h3>
<p class="post-meta"><span class="tie-date">May 19, 2018</span></p>
</div>
<div class="related-item">
<div class="post-thumbnail">
<a href="https://ecadforum.com/2018/05/19/ethiopian-pm-secures-release-of-prisoners-in-saudi-arabia/" title="Permalink to Ethiopian PM secures release of prisoners in Saudi Arabia" rel="bookmark">
<img width="300" height="160" src="https://ecadforum.com/wp-content/plugins/jetpack/modules/lazy-images/images/1x1.trans.x28145.gif" class="attachment-tie-large size-tie-large wp-post-image" alt="Mr Abiy Ahmed was speaking at a rally in the capital, Addis Ababa," data-lazy-src="https://i1.wp.com/ecadforum.com/wp-content/uploads/2018/04/Abiy-Ahmed1.jpg?resize=300%2C160&amp;ssl=1" data-lazy-srcset="https://i1.wp.com/ecadforum.com/wp-content/uploads/2018/04/Abiy-Ahmed1.jpg?w=620&amp;ssl=1 620w, https://i1.wp.com/ecadforum.com/wp-content/uploads/2018/04/Abiy-Ahmed1.jpg?resize=150%2C80&amp;ssl=1 150w, https://i1.wp.com/ecadforum.com/wp-content/uploads/2018/04/Abiy-Ahmed1.jpg?resize=300%2C160&amp;ssl=1 300w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" /> </a>
</div>
<h3><a href="https://ecadforum.com/2018/05/19/ethiopian-pm-secures-release-of-prisoners-in-saudi-arabia/" title="Permalink to Ethiopian PM secures release of prisoners in Saudi Arabia" rel="bookmark">Ethiopian PM secures release of prisoners in Saudi Arabia</a></h3>
<p class="post-meta"><span class="tie-date">May 19, 2018</span></p>
</div>
<div class="related-item">
<div class="post-thumbnail">
<a href="https://ecadforum.com/2018/05/18/ethiopia-13-years-old-abeter-worku-is-a-symbol-of-hate-crime-against-amhara/" title="Permalink to Ethiopia: 13 years old Abeter Worku is a symbol of hate crime against Amhara" rel="bookmark">
<img width="300" height="160" src="https://ecadforum.com/wp-content/plugins/jetpack/modules/lazy-images/images/1x1.trans.x28145.gif" class="attachment-tie-large size-tie-large wp-post-image" alt="13 years old Abeter Worku is a symbol of hate crime" data-lazy-src="https://i1.wp.com/ecadforum.com/wp-content/uploads/2018/05/bbc-abeter-worku.jpg?resize=300%2C160&amp;ssl=1" data-lazy-srcset="https://i1.wp.com/ecadforum.com/wp-content/uploads/2018/05/bbc-abeter-worku.jpg?w=620&amp;ssl=1 620w, https://i1.wp.com/ecadforum.com/wp-content/uploads/2018/05/bbc-abeter-worku.jpg?resize=150%2C80&amp;ssl=1 150w, https://i1.wp.com/ecadforum.com/wp-content/uploads/2018/05/bbc-abeter-worku.jpg?resize=300%2C160&amp;ssl=1 300w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" /> </a>
</div>
<h3><a href="https://ecadforum.com/2018/05/18/ethiopia-13-years-old-abeter-worku-is-a-symbol-of-hate-crime-against-amhara/" title="Permalink to Ethiopia: 13 years old Abeter Worku is a symbol of hate crime against Amhara" rel="bookmark">Ethiopia: 13 years old Abeter Worku is a symbol of hate crime against Amhara</a></h3>
<p class="post-meta"><span class="tie-date">May 18, 2018</span></p>
</div>
<div class="related-item">
<div class="post-thumbnail">
<a href="https://ecadforum.com/2018/05/18/ethiopia-professor-alemayehu-g-mariam-named-alumni-of-notable-achievement/" title="Permalink to Ethiopia: Professor Alemayehu G. Mariam named Alumni of Notable Achievement" rel="bookmark">
<img width="300" height="160" src="https://ecadforum.com/wp-content/plugins/jetpack/modules/lazy-images/images/1x1.trans.x28145.gif" class="attachment-tie-large size-tie-large wp-post-image" alt="Prof. Al Mariam" data-lazy-src="https://i1.wp.com/ecadforum.com/wp-content/uploads/2017/01/Prof.-Al-Mariam.jpg?resize=300%2C160&amp;ssl=1" data-lazy-srcset="https://i1.wp.com/ecadforum.com/wp-content/uploads/2017/01/Prof.-Al-Mariam.jpg?w=620&amp;ssl=1 620w, https://i1.wp.com/ecadforum.com/wp-content/uploads/2017/01/Prof.-Al-Mariam.jpg?resize=300%2C160&amp;ssl=1 300w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" /> </a>
</div>
<h3><a href="https://ecadforum.com/2018/05/18/ethiopia-professor-alemayehu-g-mariam-named-alumni-of-notable-achievement/" title="Permalink to Ethiopia: Professor Alemayehu G. Mariam named Alumni of Notable Achievement" rel="bookmark">Ethiopia: Professor Alemayehu G. Mariam named Alumni of Notable Achievement</a></h3>
<p class="post-meta"><span class="tie-date">May 18, 2018</span></p>
</div>
<div class="related-item">
<div class="post-thumbnail">
<a href="https://ecadforum.com/2018/05/18/esat-latest-ethiopian-news-may-18-2018/" title="Permalink to ESAT Latest Ethiopian News May 18, 2018" rel="bookmark">
<img width="300" height="160" src="https://ecadforum.com/wp-content/plugins/jetpack/modules/lazy-images/images/1x1.trans.x28145.gif" class="attachment-tie-large size-tie-large wp-post-image" alt="ESAT Latest Ethiopian News May 18, 2018." data-lazy-src="https://i1.wp.com/ecadforum.com/wp-content/uploads/2018/05/ESAT-News-May-18-2018.jpg?resize=300%2C160&amp;ssl=1" data-lazy-srcset="https://i1.wp.com/ecadforum.com/wp-content/uploads/2018/05/ESAT-News-May-18-2018.jpg?w=620&amp;ssl=1 620w, https://i1.wp.com/ecadforum.com/wp-content/uploads/2018/05/ESAT-News-May-18-2018.jpg?resize=150%2C80&amp;ssl=1 150w, https://i1.wp.com/ecadforum.com/wp-content/uploads/2018/05/ESAT-News-May-18-2018.jpg?resize=300%2C160&amp;ssl=1 300w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" /> </a>
</div>
<h3><a href="https://ecadforum.com/2018/05/18/esat-latest-ethiopian-news-may-18-2018/" title="Permalink to ESAT Latest Ethiopian News May 18, 2018" rel="bookmark">ESAT Latest Ethiopian News May 18, 2018</a></h3>
<p class="post-meta"><span class="tie-date">May 18, 2018</span></p>
</div>
<div class="clear"></div>
</div>
</section>
</div>
<aside class="sidebar-narrow">
<div id="posts-list-widget-2" class="widget posts-list"><div class="widget-top"><h4>Recent Posts </h4><div class="stripe-line"></div></div>
<div class="widget-container"> <ul>
<li>
<h3><a href="https://ecadforum.com/2018/05/21/esat-latest-ethiopian-news-may-21-2018/">ESAT Latest Ethiopian News May 21, 2018</a></h3>
<span class="date"><span class="tie-date">May 21, 2018</span></span>
</li>
<li>
<h3><a href="https://ecadforum.com/2018/05/20/memorandum-no-6-pm-abiy-preaching-walk-the-talk-in-faith/">Memorandum No. 6: PM Abiy Preaching “Walk the Talk in Faith”!</a></h3>
<span class="date"><span class="tie-date">May 20, 2018</span></span>
</li>
<li>
<h3><a href="https://ecadforum.com/2018/05/20/uncertainty-strains-ethiopian-refugees-in-a-kenya-camp/">Uncertainty Strains Ethiopian Refugees in a Kenya Camp</a></h3>
<span class="date"><span class="tie-date">May 20, 2018</span></span>
</li>
<li>
<h3><a href="https://ecadforum.com/2018/05/19/ethiopia-delivering-an-unborn-dream-left-to-us-by-history/">Ethiopia: Delivering an unborn dream left to us by history</a></h3>
<span class="date"><span class="tie-date">May 19, 2018</span></span>
</li>
<li>
<h3><a href="https://ecadforum.com/2018/05/19/real-accountability-and-the-need-to-restore-billions-of-us-dollar-to-ethiopias-poor/">Real Accountability and the Need to Restore Billions of US Dollar to Ethiopia’s Poor</a></h3>
<span class="date"><span class="tie-date">May 19, 2018</span></span>
</li>
<li>
<h3><a href="https://ecadforum.com/2018/05/19/esat-latest-ethiopian-news-may-19-2018/">ESAT Latest Ethiopian News May 19, 2018</a></h3>
<span class="date"><span class="tie-date">May 19, 2018</span></span>
</li>
</ul>
<div class="clear"></div>
</div></div> <div id="ads160_600-widget-2" class="ads160-600">
<div class="ad-cell">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-4379286819423322" data-ad-slot="5792721206"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
</div>
</aside>
</div> 
<aside class="sidebar">
<div class="search-widget">
<form method="get" id="searchform-widget" action="https://ecadforum.com/">
<input type="text" id="s" name="s" value="to search type and hit enter" onfocus="if (this.value == 'to search type and hit enter') {this.value = '';}" onblur="if (this.value == '') {this.value = 'to search type and hit enter';}" />
</form>
</div>
<div id="blog_subscription-2" class="widget jetpack_subscription_widget"><div class="widget-top"><h4>Subscribe to ECADF via Email</h4><div class="stripe-line"></div></div>
<div class="widget-container">
<form action="#" method="post" accept-charset="utf-8" id="subscribe-blog-blog_subscription-2">
<div id="subscribe-text"><p>Enter your email address to subscribe to this blog and receive notifications of new posts by email.</p>
</div> <p id="subscribe-email">
<label id="jetpack-subscribe-label" for="subscribe-field-blog_subscription-2">
Email Address </label>
<input type="email" name="email" required="required" class="required" value="" id="subscribe-field-blog_subscription-2" placeholder="Email Address" />
</p>
<p id="subscribe-submit">
<input type="hidden" name="action" value="subscribe" />
<input type="hidden" name="source" value="https://ecadforum.com/2018/05/21/esat-latest-ethiopian-news-may-21-2018/" />
<input type="hidden" name="sub-type" value="widget" />
<input type="hidden" name="redirect_fragment" value="blog_subscription-2" />
<input type="submit" value="Subscribe" name="jetpack_subscriptions_widget" />
</p>
</form>
<script>
			/*
			Custom functionality for safari and IE
			 */
			(function( d ) {
				// In case the placeholder functionality is available we remove labels
				if ( ( 'placeholder' in d.createElement( 'input' ) ) ) {
					var label = d.querySelector( 'label[for=subscribe-field-blog_subscription-2]' );
						label.style.clip 	 = 'rect(1px, 1px, 1px, 1px)';
						label.style.position = 'absolute';
						label.style.height   = '1px';
						label.style.width    = '1px';
						label.style.overflow = 'hidden';
				}

				// Make sure the email value is filled in before allowing submit
				var form = d.getElementById('subscribe-blog-blog_subscription-2'),
					input = d.getElementById('subscribe-field-blog_subscription-2'),
					handler = function( event ) {
						if ( '' === input.value ) {
							input.focus();

							if ( event.preventDefault ){
								event.preventDefault();
							}

							return false;
						}
					};

				if ( window.addEventListener ) {
					form.addEventListener( 'submit', handler, false );
				} else {
					form.attachEvent( 'onsubmit', handler );
				}
			})( document );
			</script>
</div></div><div id="custom_html-3" class="widget_text widget widget_custom_html"><div class="widget-top"><h4>Featured</h4><div class="stripe-line"></div></div>
<div class="widget-container"><div class="textwidget custom-html-widget"><h2>Ethiopian journalist Eskinder Nega receives warm welcome in Washington DC</h2>
<a href="https://ecadforum.com/2018/05/06/ethiopian-journalist-eskinder-nega-receives-warm-welcome-in-washington-dc/" rel="nofollow"><img src="https://ecadforum.com/wp-content/plugins/jetpack/modules/lazy-images/images/1x1.trans.x28145.gif" alt="Ethiopian journalist Eskinder Nega receives warm welcome." width="300" height="160" class="aligncenter size-medium wp-image-41225" data-recalc-dims="1" data-lazy-src="https://i2.wp.com/ecadforum.com/wp-content/uploads/2018/05/Eskinder-Nega-in-America3.jpg?resize=300%2C160"><noscript><img src="https://i2.wp.com/ecadforum.com/wp-content/uploads/2018/05/Eskinder-Nega-in-America3.jpg?resize=300%2C160" alt="Ethiopian journalist Eskinder Nega receives warm welcome." width="300" height="160" class="aligncenter size-medium wp-image-41225" data-recalc-dims="1" /></noscript></a>
&nbsp;
<h2>Ethiopian Journalist Eskinder Nega Undeterred by Threats to Press Freedom</h2>
<a href="https://ecadforum.com/2018/05/02/ethiopian-journalist-eskinder-nega-undeterred-by-threats-to-press-freedom/" rel="nofollow"><img src="https://ecadforum.com/wp-content/plugins/jetpack/modules/lazy-images/images/1x1.trans.x28145.gif" alt="Ethiopian authorities have arrested journalist Eskinder Nega nine times on charges that include treason, terrorism, and genocide." width="300" height="160" class="aligncenter size-medium wp-image-41199" data-recalc-dims="1" data-lazy-src="https://i0.wp.com/ecadforum.com/wp-content/uploads/2018/05/Eskinder-Nega-Undeterred.jpg?resize=300%2C160"><noscript><img src="https://i0.wp.com/ecadforum.com/wp-content/uploads/2018/05/Eskinder-Nega-Undeterred.jpg?resize=300%2C160" alt="Ethiopian authorities have arrested journalist Eskinder Nega nine times on charges that include treason, terrorism, and genocide." width="300" height="160" class="aligncenter size-medium wp-image-41199" data-recalc-dims="1" /></noscript></a></div></div></div> <div id="ads300_600-widget-7" class="ads300-600">
<div class="ad-cell">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-4379286819423322" data-ad-slot="5792721206"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
</div>
<div id="text-html-widget-14" class="text-html-box" style="text-align:center;">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-4379286819423322" data-ad-slot="7930606409" data-matched-content-ui-type="image_stacked" data-matched-content-rows-num="5" data-matched-content-columns-num="1" data-ad-format="autorelaxed"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script> </div>
<div id="eu_cookie_law_widget-2" class="widget widget_eu_cookie_law_widget"><div class="negative hide-on-time" data-hide-timeout="30" id="eu-cookie-law">
<form method="post">
<input type="submit" value="Close and accept" class="accept" />
</form>
Privacy &amp; Cookies: This site uses cookies. <br />
To find out more, as well as how to remove or block these, see here:
<a href="https://jetpack.com/support/cookies/">
Our Cookie Policy	</a>
</div>
</div></div></aside>
<div class="clear"></div> <div class="clear"></div>
</div>
</div>
<footer id="theme-footer" class="fade-in animated4">
<div id="footer-widget-area" class="footer-1c container">
<div id="footer-first" class="footer-widgets-box">
<div id="text-html-widget-8" class="text-html-box">
The views, opinions and positions expressed on ECADF Ethiopian News are the opinions of individual contributors and may not necessarily reflect the views of our website. </div>
</div>
</div>
<div class="clear"></div>
</footer>
<div class="clear"></div>
<div class="footer-bottom fade-in animated4">
<div class="container">
<div class="alignleft">
          © Copyright 2016, All Rights Reserved. | <strong><a href="https://ecadforum.com/" target="_blank" rel="nofollow noopener">ECADF Ethiopian News</a></strong>                                            <strong><a href="https://ecadforum.com/" target="_blank" rel="nofollow noopener">Home</a> |  <a href="https://ecadforum.com/Amharic/" target="_blank" rel="nofollow noopener">Amharic</a> |  <a href="https://ecadforum.com/category/video/" target="_blank" rel="nofollow noopener">Video</a> |  <a href="https://ecadforum.com/voa-amharic-radio-daily-broadcast-to-ethiopia/" target="_blank" rel="nofollow noopener">VOA</a>  |  <a href="https://ecadforum.com/contact-2/">Contact Us</a></strong> </div>
</div>
</div>
</div>
<div id="topcontrol" class="tieicon-up-open" title="Scroll To Top"></div>
<div id="fb-root"></div>
<script type='text/javascript' src='https://ecadforum.com/wp-content/plugins/jetpack/_inc/build/photon/photon.min.x28145.js'></script>
<script type='text/javascript' src='https://ecadforum.com/wp-content/plugins/anti-spam/js/anti-spam-4.4.x28145.js'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var tie = {"go_to":"Go to...","ajaxurl":"https:\/\/ecadforum.com\/wp-admin\/admin-ajax.php","your_rating":"Your Rating:","is_singular":"1","reading_indicator":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://ecadforum.com/wp-content/themes/jarida/js/tie-scripts.x28145.js'></script>
<script type='text/javascript' src='https://ecadforum.com/wp-content/plugins/jetpack/_inc/build/widgets/eu-cookie-law/eu-cookie-law.min.x28145.js'></script>
<script type='text/javascript' src='https://ecadforum.com/wp-content/plugins/jetpack/_inc/build/lazy-images/js/lazy-images.min.x28145.js'></script>
<script type='text/javascript' src='https://ecadforum.com/wp-content/plugins/youtube-embed-plus/scripts/fitvids.min.x28145.js'></script>
<script type='text/javascript' src='https://ecadforum.com/wp-includes/js/wp-embed.min.x28145.js'></script>
<script async="async" type='text/javascript' src='https://ecadforum.com/wp-content/plugins/akismet/_inc/form.x28145.js'></script>

<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=787806777997466&version=v2.3";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>
<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=21932601&postid=41387&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=transparent&lang=en_US&jetpack_version=6.1&sig=598a19b4389b9539c9859468a44209706fbf23ab#parent=https%3A%2F%2Fecadforum.com%2F2018%2F05%2F21%2Fesat-latest-ethiopian-news-may-21-2018%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=21932601&postid=41387&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=transparent&lang=en_US&jetpack_version=6.1&sig=598a19b4389b9539c9859468a44209706fbf23ab#parent=https%3A%2F%2Fecadforum.com%2F2018%2F05%2F21%2Fesat-latest-ethiopian-news-may-21-2018%2F";
					}
				};

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>
<script type='text/javascript' src='https://stats.wp.com/e-201821.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:6.1',blog:'21932601',post:'41387',tz:'-7',srv:'ecadforum.com'} ]);
	_stq.push([ 'clickTrackerInit', '21932601', '41387' ]);
</script>
</body>
</html>
