<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
<meta charset="UTF-8" />
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="pingback" href="https://ecadforum.com/xmlrpc.php" />
<title>Ethiopia: Neamin Zeleke and Ermias Legesse at the Los Angeles Town Hall Meeting</title>

<meta property="og:type" content="article" />
<meta property="og:title" content="Ethiopia: Neamin Zeleke and Ermias Legesse at the Los Angeles Town Hall Meeting" />
<meta property="og:description" content="'Ethiopian people, inside and outside, must continue to wage a vigorous struggle to bring about a fundamental and systemic change' Neamin Zeleke" />
<meta property="og:image" content="https://ecadforum.com/wp-content/uploads/2018/03/Neamin-and-Ermias-LA.jpg" />
<meta property="og:url" content="https://ecadforum.com/2018/03/17/ethiopia-neamin-zeleke-and-ermias-legesse-at-the-los-angeles-town-hall-meeting/" />
<meta property="og:site_name" content="ECADF Ethiopian News" />
<meta property="article:publisher" content="https://www.facebook.com/ethiopianews" />
<meta property="article:published_time" content="2018-03-17T06:14:16+00:00" />
<meta property="article:modified_time" content="2018-03-17T06:14:16+00:00" />
<meta property="og:updated_time" content="2018-03-17T06:14:16+00:00" />


<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:title" content="Ethiopia: Neamin Zeleke and Ermias Legesse at the Los Angeles Town Hall Meeting">
<meta name="twitter:description" content="'Ethiopian people, inside and outside, must continue to wage a vigorous struggle to bring about a fundamental and systemic change' Neamin Zeleke">
<meta name="twitter:image" content="https://ecadforum.com/wp-content/uploads/2018/03/Neamin-and-Ermias-LA.jpg">
<meta name="twitter:site" content="@ecadf">
<meta name="twitter:creator" content="@ecadf">




<link rel="author" href="https://plus.google.com/u/0/+EcadfEthiopiaNews/posts" />
<meta name="description" content="&#039;Ethiopian people, inside and outside, must continue to wage a vigorous struggle to bring about a fundamental and systemic change&#039; Neamin Zeleke" />
<meta name="keywords" content="ethiopia,ethiopian news,patriotic ginbot 7,tplf,video" />
<meta name="robots" content="index,nofollow" />
<link rel="canonical" href="https://ecadforum.com/2018/03/17/ethiopia-neamin-zeleke-and-ermias-legesse-at-the-los-angeles-town-hall-meeting/" />
<script type="text/javascript">
				window.ga=window.ga||function(){(ga.q=ga.q||[]).push(arguments)};ga.l=+new Date;
				ga('create', 'UA-9883609-1', { 'cookieDomain': 'ecadforum.com' } );
				// Plugins
				ga('require', 'ec');ga('require', 'linkid', 'linkid.js');ga('set', 'anonymizeIp', true);ga('require', 'outboundLinkTracker');ga('require', 'outboundFormTracker');ga('require', 'eventTracker');ga('require', 'urlChangeTracker');ga('require', 'pageVisibilityTracker');ga('require', 'mediaQueryTracker');ga('require', 'impressionTracker');ga('require', 'maxScrollTracker');ga('require', 'socialWidgetTracker');ga('require', 'cleanUrlTracker');
				ga('send', 'pageview');
			</script>
<script async src="https://www.google-analytics.com/analytics.js"></script>
<script async src="https://ecadforum.com/wp-content/plugins/all-in-one-seo-pack-pro/public/js/vendor/autotrack.x41962.js"></script>

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="ECADF Ethiopian News &raquo; Feed" href="https://ecadforum.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="ECADF Ethiopian News &raquo; Comments Feed" href="https://ecadforum.com/comments/feed/" />
<script>
var MP3jPLAYLISTS = [];
var MP3jPLAYERS = [];
</script>
<link rel="alternate" type="application/rss+xml" title="ECADF Ethiopian News &raquo; Ethiopia: Neamin Zeleke and Ermias Legesse at the Los Angeles Town Hall Meeting Comments Feed" href="https://ecadforum.com/2018/03/17/ethiopia-neamin-zeleke-and-ermias-legesse-at-the-los-angeles-town-hall-meeting/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/ecadforum.com\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='mashsb-styles-css' href='https://ecadforum.com/wp-content/plugins/mashsharer/assets/css/mashsb.min.x41962.css' type='text/css' media='all' />
<style id='mashsb-styles-inline-css' type='text/css'>
.mashsb-count {color:#9a9b9c;}
        [class^="mashicon-"], .onoffswitch-label, .onoffswitch2-label, .onoffswitch {
            border-radius: 2px;
        }@media only screen and (min-width:568px){.mashsb-buttons a {min-width: 177px;}}
</style>
<link rel='stylesheet' id='tie-style-css' href='https://ecadforum.com/wp-content/themes/jarida/style.x41962.css' type='text/css' media='all' />
<link rel='stylesheet' id='Roboto+Condensed-css' href='https://fonts.googleapis.com/css?family=Roboto+Condensed%3A300%2C300italic%2Cregular%2Citalic%2C700%2C700italic' type='text/css' media='all' />
<link rel='stylesheet' id='Oswald-css' href='https://fonts.googleapis.com/css?family=Oswald%3Aregular%2C700' type='text/css' media='all' />

<style id='jetpack_facebook_likebox-inline-css' type='text/css'>
.widget_facebook_likebox {
	overflow: hidden;
}

</style>
<link rel='stylesheet' id='mp3-jplayer-css' href='https://ecadforum.com/wp-content/plugins/mp3-jplayer/css/dark.x41962.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://ecadforum.com/wp-content/plugins/jetpack/css/jetpack.x41962.css' type='text/css' media='all' />
<script type='text/javascript' src='https://ecadforum.com/wp-includes/js/jquery/jquery.x41962.js'></script>
<script type='text/javascript' src='https://ecadforum.com/wp-includes/js/jquery/jquery-migrate.min.x41962.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mashsb = {"shares":"546","round_shares":"1","animate_shares":"0","dynamic_buttons":"0","share_url":"https:\/\/ecadforum.com\/2018\/03\/17\/ethiopia-neamin-zeleke-and-ermias-legesse-at-the-los-angeles-town-hall-meeting\/","title":"Ethiopia%3A+Neamin+Zeleke+and+Ermias+Legesse+at+the+Los+Angeles+Town+Hall+Meeting","image":"https:\/\/ecadforum.com\/wp-content\/uploads\/2018\/03\/Neamin-and-Ermias-LA.jpg","desc":"'Ethiopian people, inside and outside, must continue to wage a vigorous struggle to bring about a fundamental and systemic change' Neamin Zeleke","hashtag":"ecadf","subscribe":"content","subscribe_url":"","activestatus":"1","singular":"1","twitter_popup":"1","refresh":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://ecadforum.com/wp-content/plugins/mashsharer/assets/js/mashsb.min.x41962.js'></script>
<link rel='https://api.w.org/' href='https://ecadforum.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://ecadforum.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://ecadforum.com/wp-includes/wlwmanifest.xml" />
<link rel='prev' title='Time for Political Change and Unity in Ethiopia' href='https://ecadforum.com/2018/03/17/time-for-political-change-and-unity-in-ethiopia/' />
<meta name="generator" content="WordPress 4.9.4" />
<link rel='shortlink' href='https://ecadforum.com/?p=40665' />
<link rel="alternate" type="application/json+oembed" href="https://ecadforum.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fecadforum.com%2F2018%2F03%2F17%2Fethiopia-neamin-zeleke-and-ermias-legesse-at-the-los-angeles-town-hall-meeting%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://ecadforum.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fecadforum.com%2F2018%2F03%2F17%2Fethiopia-neamin-zeleke-and-ermias-legesse-at-the-los-angeles-town-hall-meeting%2F&#038;format=xml" />
<meta property="fb:app_id" content="787806777997466" />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<link rel="shortcut icon" href="https://ecadforum.com/wp-content/uploads/2015/10/ECADF-iPad-Icon.x41962.png" title="Favicon" /><!--[if IE]>
<script type="text/javascript">jQuery(document).ready(function (){ jQuery(".menu-item").has("ul").children("a").attr("aria-haspopup", "true");});</script>
<![endif]-->
<!--[if lt IE 9]>
<script src="https://ecadforum.com/wp-content/themes/jarida/js/html5.x41962.js"></script>
<script src="https://ecadforum.com/wp-content/themes/jarida/js/selectivizr-min.x41962.js"></script>
<![endif]-->
<!--[if IE 8]>
<link rel="stylesheet" type="text/css" media="all" href="https://ecadforum.com/wp-content/themes/jarida/css/ie8.x41962.css" />
<![endif]-->
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1" />
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1, user-scalable=no" />
<style type="text/css" media="screen">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</style>
<link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://ecadforum.com/wp-content/uploads/2015/10/ECADF-iPad-Retina-Icon.x41962.png" />
<link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://ecadforum.com/wp-content/uploads/2015/10/ECADF-iPhone-Retina-Icon.x41962.png" />
<link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://ecadforum.com/wp-content/uploads/2015/10/ECADF-iPad-Icon1.x41962.png" />
<link rel="apple-touch-icon-precomposed" href="https://ecadforum.com/wp-content/uploads/2015/10/ECADF-iPhone-Icon.x41962.png" />
<style type="text/css">.broken_link, a.broken_link {
	text-decoration: line-through;
}</style><link rel="alternate" href="https://ecadforum.com" hreflang="en-us" />
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
</head>
<body id="top" class="post-template-default single single-post postid-40665 single-format-standard">
<div class="background-cover"></div>
<div class="wrapper">
<div class="container">
<header id="theme-header">
<div class="header-content fade-in animated1">
<div class="logo">
<h2> <a title="ECADF Ethiopian News" href="https://ecadforum.com/">
<img src="https://ecadforum.com/wp-content/uploads/2017/08/ecadf-logo-2017.x41962.png" alt="ECADF Ethiopian News" /><strong>ECADF Ethiopian News Ethiopian news, video and opinions</strong>
</a>
</h2> </div>
<div class="clear"></div>
</div>
<nav id="main-nav" class="fade-in animated2">
<div class="container">
<div class="main-menu"><ul id="menu-category" class="menu"><li id="menu-item-601" class="menu-item  menu-item-type-custom  menu-item-object-custom  menu-item-home"><a href="https://ecadforum.com">Home</a></li>
<li id="menu-item-7476" class="menu-item  menu-item-type-custom  menu-item-object-custom"><a href="https://www.ecadforum.com/Amharic/">Amharic</a></li>
<li id="menu-item-26255" class="menu-item  menu-item-type-taxonomy  menu-item-object-category  current-post-ancestor  current-menu-parent  current-post-parent"><a href="https://ecadforum.com/category/video/">Video</a></li>
<li id="menu-item-37780" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="https://ecadforum.com/category/ethiopianmusic/">Music Video</a></li>
<li id="menu-item-14642" class="menu-item  menu-item-type-custom  menu-item-object-custom"><a title="VOA Amharic radio" href="https://ecadforum.com/voa-amharic-radio-daily-broadcast-to-ethiopia/">VOA</a></li>
<li id="menu-item-26052" class="menu-item  menu-item-type-custom  menu-item-object-custom  menu-item-has-children"><a>Categories</a>
<ul class="sub-menu">
<li id="menu-item-26047" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="https://ecadforum.com/category/news/">News</a></li>
<li id="menu-item-26049" class="menu-item  menu-item-type-taxonomy  menu-item-object-category  current-post-ancestor  current-menu-parent  current-post-parent"><a rel="nofollow" href="https://ecadforum.com/category/video/">Video</a></li>
<li id="menu-item-37782" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a rel="nofollow" href="https://ecadforum.com/category/ethiopianmusic/">Music Video</a></li>
<li id="menu-item-26048" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="https://ecadforum.com/category/opinion/">Opinions</a></li>
<li id="menu-item-26050" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="https://ecadforum.com/category/events/">Events</a></li>
<li id="menu-item-26051" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="https://ecadforum.com/category/sport/">Sport</a></li>
</ul> 
</li>
<li id="menu-item-28217" class="menu-item  menu-item-type-custom  menu-item-object-custom  menu-item-has-children"><a>Social media</a>
<ul class="sub-menu">
<li id="menu-item-25967" class="menu-item  menu-item-type-custom  menu-item-object-custom"><a rel="nofollow" href="https://www.facebook.com/ethiopianews" target="_blank">Facebook</a></li>
<li id="menu-item-25968" class="menu-item  menu-item-type-custom  menu-item-object-custom"><a rel="nofollow" href="https://twitter.com/ECADF" target="_blank">Twitter</a></li>
<li id="menu-item-25969" class="menu-item  menu-item-type-custom  menu-item-object-custom"><a rel="nofollow" href="https://www.youtube.com/user/ecadfethiopia/videos" target="_blank">YouTube</a></li>
<li id="menu-item-7006" class="menu-item  menu-item-type-custom  menu-item-object-custom"><a title="nofollow" href="https://ecadforum.com/ecadf-chat-room/">Paltalk</a></li>
</ul> 
</li>
<li id="menu-item-38672" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="https://ecadforum.com/archive/">Archive</a></li>
<li id="menu-item-26010" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a rel="nofollow" href="https://ecadforum.com/contact-2/">Contact Us</a></li>
</ul></div> </div>
</nav>
</header>
<div id="main-content" class="container fade-in animated3 sidebar-narrow-left">
<div class="content-wrap">
<div class="content">
<div xmlns:v="http://rdf.data-vocabulary.org/#" id="crumbs"><span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" class="crumbs-home" href="https://ecadforum.com"><i class="tieicon-home"></i>Home</a></span> &raquo; <span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" href="https://ecadforum.com/category/video/">Video</a></span> &raquo; <span class="current">Ethiopia: Neamin Zeleke and Ermias Legesse at the Los Angeles Town Hall Meeting</span></div>
<article id="the-post" class="post-listing post-40665 post type-post status-publish format-standard has-post-thumbnail hentry category-video tag-ethiopia tag-ethiopian-news tag-patriotic-ginbot-7 tag-tplf">
<div class="post-inner">
<h1 class="name post-title entry-title" itemprop="itemReviewed" itemscope itemtype="http://schema.org/Thing"><span itemprop="name">Ethiopia: Neamin Zeleke and Ermias Legesse at the Los Angeles Town Hall Meeting</span></h1>
<p class="post-meta">
<span class="post-meta-author">Posted by: <a href="https://ecadforum.com/author/ecadforum/" title="">ecadforum </a></span>
<span class="post-cats">in <a href="https://ecadforum.com/category/video/" rel="category tag">Video</a></span>
<span class="tie-date">March 17, 2018</span>
</p>
<div class="clear"></div>
<div style="float:none;margin:0px 0 0px 0;text-align:center;">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-4379286819423322" data-ad-slot="5792721206"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<div class="entry">
<aside class="mashsb-container mashsb-main mashsb-stretched">
<div class="mashsb-box">
<div class="mashsb-count mash-large" style="float:left;">
<div class="counts mashsbcount">546</div>
<p><span class="mashsb-sharetext">SHARES</span></div>
<div class="mashsb-buttons"><a class="mashicon-facebook mash-large mash-center mashsb-noshadow" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fecadforum.com%2F2018%2F03%2F17%2Fethiopia-neamin-zeleke-and-ermias-legesse-at-the-los-angeles-town-hall-meeting%2F" target="_blank" rel="nofollow"><span class="icon"></span><span class="text">Share</span></a><a class="mashicon-twitter mash-large mash-center mashsb-noshadow" href="https://twitter.com/intent/tweet?text=Ethiopia%3A%20Neamin%20Zeleke%20and%20Ermias%20Legesse%20at%20the%20Los%20Angeles%20Town%20Hall%20Meeting&#038;url=https://goo.gl/kVcxpJ&#038;via=ecadf" target="_blank" rel="nofollow"><span class="icon"></span><span class="text">Tweet</span></a></p>
<div class="onoffswitch2 mash-large mashsb-noshadow" style="display:none;"></div>
</div></div>
<div style="clear:both;"></div>
<div class="mashsb-toggle-container"></div>
</aside>
<p> <strong>Neamin Zeleke, member of Patriotic Ginbot 7 Leadership and Ermias Legesse of ESAT Los Angeles Town Hall Meeting</strong></p>
<p style="padding-left: 30px;"><em><strong>&#8220;Ethiopian people, inside and outside, must continue to wage a vigorous struggle to bring about a fundamental and systemic change, a democratic Ethiopia that is just , equal to all citizens and all ethnic groups&#8221; </strong>Neamin Zeleke </em></p>
<p><iframe width="640" height="360" src="https://www.youtube.com/embed/29hcEv4fnOw" frameborder="0" allow="autoplay; encrypted-media" allowfullscreen></iframe></p>
</div>
<span style="display:none"><a href="https://ecadforum.com/tag/ethiopia/" rel="tag">Ethiopia</a> <a href="https://ecadforum.com/tag/ethiopian-news/" rel="tag">Ethiopian News</a> <a href="https://ecadforum.com/tag/patriotic-ginbot-7/" rel="tag">Patriotic Ginbot 7</a> <a href="https://ecadforum.com/tag/tplf/" rel="tag">TPLF</a></span> <span style="display:none" class="updated">2018-03-17</span>
<div style="display:none" class="vcard author" itemprop="author" itemscope itemtype="http://schema.org/Person"><strong class="fn" itemprop="name"><a href="https://plus.google.com/u/0/b/113621583050101745316/+Ecadforumethiopia/posts?rel=author">+ecadforum</a></strong></div>
</div>
</article>
<p class="post-tag">Tagged with: <a href="https://ecadforum.com/tag/ethiopia/" rel="tag">Ethiopia</a> <a href="https://ecadforum.com/tag/ethiopian-news/" rel="tag">Ethiopian News</a> <a href="https://ecadforum.com/tag/patriotic-ginbot-7/" rel="tag">Patriotic Ginbot 7</a> <a href="https://ecadforum.com/tag/tplf/" rel="tag">TPLF</a></p>
<section id="related_posts">
<div class="block-head">
<h3>Related Posts</h3><div class="stripe-line"></div>
</div>
<div class="post-listing">
<div class="related-item">
<div class="post-thumbnail">
<a href="https://ecadforum.com/2018/03/17/time-for-political-change-and-unity-in-ethiopia/" title="Permalink to Time for Political Change and Unity in Ethiopia" rel="bookmark">
<img width="300" height="160" src="https://ecadforum.com/wp-content/plugins/jetpack/modules/lazy-images/images/1x1.trans.x41962.gif" class="attachment-tie-large size-tie-large wp-post-image" alt="Moyale town residents are crossing the border to Kenya." data-lazy-src="https://i1.wp.com/ecadforum.com/wp-content/uploads/2018/03/Residents-of-Moyale.jpg?resize=300%2C160&amp;ssl=1" data-lazy-srcset="https://i1.wp.com/ecadforum.com/wp-content/uploads/2018/03/Residents-of-Moyale.jpg?w=620&amp;ssl=1 620w, https://i1.wp.com/ecadforum.com/wp-content/uploads/2018/03/Residents-of-Moyale.jpg?resize=300%2C160&amp;ssl=1 300w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" /> </a>
</div>
<h3><a href="https://ecadforum.com/2018/03/17/time-for-political-change-and-unity-in-ethiopia/" title="Permalink to Time for Political Change and Unity in Ethiopia" rel="bookmark">Time for Political Change and Unity in Ethiopia</a></h3>
<p class="post-meta"><span class="tie-date">March 17, 2018</span></p>
</div>
<div class="related-item">
<div class="post-thumbnail">
<a href="https://ecadforum.com/2018/03/16/debretsion-gebremichael-is-the-new-massacre-in-chief-in-addis-ababa/" title="Permalink to Debretsion Gebremichael Is The New Massacre in Chief in Addis Ababa" rel="bookmark">
<img width="300" height="160" src="https://ecadforum.com/wp-content/plugins/jetpack/modules/lazy-images/images/1x1.trans.x41962.gif" class="attachment-tie-large size-tie-large wp-post-image" alt="Debretsion Gebremichael, minister of communication and information technology." data-lazy-src="https://i0.wp.com/ecadforum.com/wp-content/uploads/2016/09/CDO-Debretsion.jpg?resize=300%2C160&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/ecadforum.com/wp-content/uploads/2016/09/CDO-Debretsion.jpg?w=620&amp;ssl=1 620w, https://i0.wp.com/ecadforum.com/wp-content/uploads/2016/09/CDO-Debretsion.jpg?resize=300%2C160&amp;ssl=1 300w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" /> </a>
</div>
<h3><a href="https://ecadforum.com/2018/03/16/debretsion-gebremichael-is-the-new-massacre-in-chief-in-addis-ababa/" title="Permalink to Debretsion Gebremichael Is The New Massacre in Chief in Addis Ababa" rel="bookmark">Debretsion Gebremichael Is The New Massacre in Chief in Addis Ababa</a></h3>
<p class="post-meta"><span class="tie-date">March 16, 2018</span></p>
</div>
<div class="related-item">
<div class="post-thumbnail">
<a href="https://ecadforum.com/2018/03/16/esat-latest-ethiopian-news-march-16-2018/" title="Permalink to ESAT Latest Ethiopian News March 16, 2018" rel="bookmark">
<img width="300" height="160" src="https://ecadforum.com/wp-content/plugins/jetpack/modules/lazy-images/images/1x1.trans.x41962.gif" class="attachment-tie-large size-tie-large wp-post-image" alt="ESAT Latest Ethiopian News March 16, 2018." data-lazy-src="https://i0.wp.com/ecadforum.com/wp-content/uploads/2018/03/ESAT-News-March-16-2018.jpg?resize=300%2C160&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/ecadforum.com/wp-content/uploads/2018/03/ESAT-News-March-16-2018.jpg?w=620&amp;ssl=1 620w, https://i0.wp.com/ecadforum.com/wp-content/uploads/2018/03/ESAT-News-March-16-2018.jpg?resize=300%2C160&amp;ssl=1 300w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" /> </a>
</div>
<h3><a href="https://ecadforum.com/2018/03/16/esat-latest-ethiopian-news-march-16-2018/" title="Permalink to ESAT Latest Ethiopian News March 16, 2018" rel="bookmark">ESAT Latest Ethiopian News March 16, 2018</a></h3>
<p class="post-meta"><span class="tie-date">March 16, 2018</span></p>
</div>
<div class="related-item">
<div class="post-thumbnail">
<a href="https://ecadforum.com/2018/03/16/the-ethiopian-powder-keg-is-a-regional-threat/" title="Permalink to The Ethiopian Powder Keg Is a Regional Threat" rel="bookmark">
<img width="300" height="160" src="https://ecadforum.com/wp-content/plugins/jetpack/modules/lazy-images/images/1x1.trans.x41962.gif" class="attachment-tie-large size-tie-large wp-post-image" alt="Security personnel attempt to stop protesters" data-lazy-src="https://i0.wp.com/ecadforum.com/wp-content/uploads/2016/10/Irreecha27.jpg?resize=300%2C160&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/ecadforum.com/wp-content/uploads/2016/10/Irreecha27.jpg?w=620&amp;ssl=1 620w, https://i0.wp.com/ecadforum.com/wp-content/uploads/2016/10/Irreecha27.jpg?resize=300%2C160&amp;ssl=1 300w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" /> </a>
</div>
<h3><a href="https://ecadforum.com/2018/03/16/the-ethiopian-powder-keg-is-a-regional-threat/" title="Permalink to The Ethiopian Powder Keg Is a Regional Threat" rel="bookmark">The Ethiopian Powder Keg Is a Regional Threat</a></h3>
<p class="post-meta"><span class="tie-date">March 16, 2018</span></p>
</div>
<div class="related-item">
<div class="post-thumbnail">
<a href="https://ecadforum.com/2018/03/16/ethiopias-recurrent-state-of-siege/" title="Permalink to Ethiopia’s Recurrent State of Siege" rel="bookmark">
<img width="300" height="160" src="https://ecadforum.com/wp-content/plugins/jetpack/modules/lazy-images/images/1x1.trans.x41962.gif" class="attachment-tie-large size-tie-large wp-post-image" alt="A Glimpse into the Amhara Awakening" data-lazy-src="https://i0.wp.com/ecadforum.com/wp-content/uploads/2016/09/Amhara-Awakening.jpg?resize=300%2C160&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/ecadforum.com/wp-content/uploads/2016/09/Amhara-Awakening.jpg?w=620&amp;ssl=1 620w, https://i0.wp.com/ecadforum.com/wp-content/uploads/2016/09/Amhara-Awakening.jpg?resize=300%2C160&amp;ssl=1 300w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" /> </a>
</div>
<h3><a href="https://ecadforum.com/2018/03/16/ethiopias-recurrent-state-of-siege/" title="Permalink to Ethiopia’s Recurrent State of Siege" rel="bookmark">Ethiopia’s Recurrent State of Siege</a></h3>
<p class="post-meta"><span class="tie-date">March 16, 2018</span></p>
</div>
<div class="related-item">
<div class="post-thumbnail">
<a href="https://ecadforum.com/2018/03/16/ethiopia-more-than-7-regime-soldiers-killed-trying-to-seize-guns/" title="Permalink to Ethiopia: More than 7 regime soldiers killed trying to seize guns" rel="bookmark">
<img width="300" height="160" src="https://ecadforum.com/wp-content/plugins/jetpack/modules/lazy-images/images/1x1.trans.x41962.gif" class="attachment-tie-large size-tie-large wp-post-image" alt="Amhara region of Ethiopia, North Gondar Zone (Semien Gondar)." data-lazy-src="https://i0.wp.com/ecadforum.com/wp-content/uploads/2018/03/Semien-Gondar.jpg?resize=300%2C160&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/ecadforum.com/wp-content/uploads/2018/03/Semien-Gondar.jpg?w=620&amp;ssl=1 620w, https://i0.wp.com/ecadforum.com/wp-content/uploads/2018/03/Semien-Gondar.jpg?resize=300%2C160&amp;ssl=1 300w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" /> </a>
</div>
<h3><a href="https://ecadforum.com/2018/03/16/ethiopia-more-than-7-regime-soldiers-killed-trying-to-seize-guns/" title="Permalink to Ethiopia: More than 7 regime soldiers killed trying to seize guns" rel="bookmark">Ethiopia: More than 7 regime soldiers killed trying to seize guns</a></h3>
<p class="post-meta"><span class="tie-date">March 16, 2018</span></p>
</div>
<div class="related-item">
<div class="post-thumbnail">
<a href="https://ecadforum.com/2018/03/16/ethiopia-crisis-is-the-beginning-of-the-end-of-autocracy-kenyan-security-expert/" title="Permalink to Ethiopia crisis is &#8216;the beginning of the end of autocracy&#8217; &#8211; Kenyan security expert" rel="bookmark">
<img width="300" height="160" src="https://ecadforum.com/wp-content/plugins/jetpack/modules/lazy-images/images/1x1.trans.x41962.gif" class="attachment-tie-large size-tie-large wp-post-image" alt="Kenyan security expert, Hassan Khannenje," data-lazy-src="https://i2.wp.com/ecadforum.com/wp-content/uploads/2018/03/Hassan-Khannenje.jpg?resize=300%2C160&amp;ssl=1" data-lazy-srcset="https://i2.wp.com/ecadforum.com/wp-content/uploads/2018/03/Hassan-Khannenje.jpg?w=620&amp;ssl=1 620w, https://i2.wp.com/ecadforum.com/wp-content/uploads/2018/03/Hassan-Khannenje.jpg?resize=300%2C160&amp;ssl=1 300w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" /> </a>
</div>
<h3><a href="https://ecadforum.com/2018/03/16/ethiopia-crisis-is-the-beginning-of-the-end-of-autocracy-kenyan-security-expert/" title="Permalink to Ethiopia crisis is &#8216;the beginning of the end of autocracy&#8217; &#8211; Kenyan security expert" rel="bookmark">Ethiopia crisis is &#8216;the beginning of the end of autocracy&#8217; &#8211; Kenyan security expert</a></h3>
<p class="post-meta"><span class="tie-date">March 16, 2018</span></p>
</div>
<div class="related-item">
<div class="post-thumbnail">
<a href="https://ecadforum.com/2018/03/16/he-owns-much-of-ethiopia-the-saudis-wont-say-where-theyre-keeping-him/" title="Permalink to He Owns Much of Ethiopia: The Saudis Won’t Say Where They’re Keeping Him" rel="bookmark">
<img width="300" height="160" src="https://ecadforum.com/wp-content/plugins/jetpack/modules/lazy-images/images/1x1.trans.x41962.gif" class="attachment-tie-large size-tie-large wp-post-image" alt="The Saudis Won’t Say Where They’re Keeping Al Amoudi." data-lazy-src="https://i1.wp.com/ecadforum.com/wp-content/uploads/2018/03/Mr-Amoudi.jpg?resize=300%2C160&amp;ssl=1" data-lazy-srcset="https://i1.wp.com/ecadforum.com/wp-content/uploads/2018/03/Mr-Amoudi.jpg?w=620&amp;ssl=1 620w, https://i1.wp.com/ecadforum.com/wp-content/uploads/2018/03/Mr-Amoudi.jpg?resize=300%2C160&amp;ssl=1 300w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" /> </a>
</div>
<h3><a href="https://ecadforum.com/2018/03/16/he-owns-much-of-ethiopia-the-saudis-wont-say-where-theyre-keeping-him/" title="Permalink to He Owns Much of Ethiopia: The Saudis Won’t Say Where They’re Keeping Him" rel="bookmark">He Owns Much of Ethiopia: The Saudis Won’t Say Where They’re Keeping Him</a></h3>
<p class="post-meta"><span class="tie-date">March 16, 2018</span></p>
</div>
<div class="related-item">
<div class="post-thumbnail">
<a href="https://ecadforum.com/2018/03/15/esat-latest-ethiopian-news-march-15-2018/" title="Permalink to ESAT Latest Ethiopian News March 15, 2018" rel="bookmark">
<img width="300" height="160" src="https://ecadforum.com/wp-content/plugins/jetpack/modules/lazy-images/images/1x1.trans.x41962.gif" class="attachment-tie-large size-tie-large wp-post-image" alt="ESAT Latest Ethiopian News March 15, 2018." data-lazy-src="https://i1.wp.com/ecadforum.com/wp-content/uploads/2018/03/ESAT-News-March-15-2018.jpg?resize=300%2C160&amp;ssl=1" data-lazy-srcset="https://i1.wp.com/ecadforum.com/wp-content/uploads/2018/03/ESAT-News-March-15-2018.jpg?w=620&amp;ssl=1 620w, https://i1.wp.com/ecadforum.com/wp-content/uploads/2018/03/ESAT-News-March-15-2018.jpg?resize=300%2C160&amp;ssl=1 300w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" /> </a>
</div>
<h3><a href="https://ecadforum.com/2018/03/15/esat-latest-ethiopian-news-march-15-2018/" title="Permalink to ESAT Latest Ethiopian News March 15, 2018" rel="bookmark">ESAT Latest Ethiopian News March 15, 2018</a></h3>
<p class="post-meta"><span class="tie-date">March 15, 2018</span></p>
</div>
<div class="clear"></div>
</div>
</section>
<div id="comments">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2018/03/17/ethiopia-neamin-zeleke-and-ermias-legesse-at-the-los-angeles-town-hall-meeting/#respond" style="display:none;">Cancel reply</a></small></h3> <form action="https://ecadforum.com/wp-comments-post.php" method="post" id="commentform" class="comment-form">
<p class="comment-notes">Your email address will not be published. Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" aria-required="true" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name</label> <span class="required">*</span><input id="author" name="author" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-email"><label for="email">Email</label> <span class="required">*</span><input id="email" name="email" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-url"><label for="url">Website</label><input id="url" name="url" type="text" value="" size="30" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='40665' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="888ac671b3" /></p> <p class="antispam-group antispam-group-q" style="clear: both;">
<label>Current <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="81f8e4c1f3">[email&#160;protected]</a> <span class="required">*</span></label>
<input type="hidden" name="antspm-a" class="antispam-control antispam-control-a" value="2018" />
<input type="text" name="antspm-q" class="antispam-control antispam-control-q" value="4.4" autocomplete="off" />
</p>
<p class="antispam-group antispam-group-e" style="display: none;">
<label>Leave this field empty</label>
<input type="text" name="antspm-e-email-url-website" class="antispam-control antispam-control-e" value="" autocomplete="off" />
</p>
<p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="46" /></p> </form>
</div>
</div>
</div>
<aside class="sidebar-narrow">
<div id="posts-list-widget-2" class="widget posts-list"><div class="widget-top"><h4>Recent Posts </h4><div class="stripe-line"></div></div>
<div class="widget-container"> <ul>
<li>
<h3><a href="https://ecadforum.com/2018/03/17/ethiopia-neamin-zeleke-and-ermias-legesse-at-the-los-angeles-town-hall-meeting/">Ethiopia: Neamin Zeleke and Ermias Legesse at the Los Angeles Town Hall Meeting</a></h3>
<span class="date"><span class="tie-date">March 17, 2018</span></span>
</li>
<li>
<h3><a href="https://ecadforum.com/2018/03/17/time-for-political-change-and-unity-in-ethiopia/">Time for Political Change and Unity in Ethiopia</a></h3>
<span class="date"><span class="tie-date">March 17, 2018</span></span>
</li>
<li>
<h3><a href="https://ecadforum.com/2018/03/16/debretsion-gebremichael-is-the-new-massacre-in-chief-in-addis-ababa/">Debretsion Gebremichael Is The New Massacre in Chief in Addis Ababa</a></h3>
<span class="date"><span class="tie-date">March 16, 2018</span></span>
</li>
<li>
<h3><a href="https://ecadforum.com/2018/03/16/esat-latest-ethiopian-news-march-16-2018/">ESAT Latest Ethiopian News March 16, 2018</a></h3>
<span class="date"><span class="tie-date">March 16, 2018</span></span>
</li>
<li>
<h3><a href="https://ecadforum.com/2018/03/16/the-ethiopian-powder-keg-is-a-regional-threat/">The Ethiopian Powder Keg Is a Regional Threat</a></h3>
<span class="date"><span class="tie-date">March 16, 2018</span></span>
</li>
<li>
<h3><a href="https://ecadforum.com/2018/03/16/ethiopias-recurrent-state-of-siege/">Ethiopia’s Recurrent State of Siege</a></h3>
<span class="date"><span class="tie-date">March 16, 2018</span></span>
</li>
</ul>
<div class="clear"></div>
</div></div> <div id="ads160_600-widget-2" class="ads160-600">
<div class="ad-cell">
<script data-cfasync="false" src="/cdn-cgi/scripts/d07b1474/cloudflare-static/email-decode.min.js"></script><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-4379286819423322" data-ad-slot="5792721206"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
</div>
</aside>
</div> 
<aside class="sidebar">
<div class="search-widget">
<form method="get" id="searchform-widget" action="https://ecadforum.com/">
<input type="text" id="s" name="s" value="to search type and hit enter" onfocus="if (this.value == 'to search type and hit enter') {this.value = '';}" onblur="if (this.value == '') {this.value = 'to search type and hit enter';}" />
</form>
</div>
<div id="custom_html-3" class="widget_text widget widget_custom_html"><div class="widget-top"><h4>Featured</h4><div class="stripe-line"></div></div>
<div class="widget-container"><div class="textwidget custom-html-widget"><h2>Special memorial anniversary ceremony for patriot Gobe in Gondar</h2>
<a href="https://ecadforum.com/2018/02/27/special-memorial-anniversary-ceremony-for-patriot-gobe-in-gondar/" rel="nofollow"><img class="aligncenter size-medium wp-image-40461" src="https://ecadforum.com/wp-content/plugins/jetpack/modules/lazy-images/images/1x1.trans.x41962.gif" alt="A special jubilee anniversary memorial ceremony held for patriotic Gobe in Gondar." width="300" height="160" data-recalc-dims="1" data-lazy-src="https://i2.wp.com/ecadforum.com/wp-content/uploads/2018/02/Gobe-Memorial.jpg?resize=300%2C160"><noscript><img class="aligncenter size-medium wp-image-40461" src="https://i2.wp.com/ecadforum.com/wp-content/uploads/2018/02/Gobe-Memorial.jpg?resize=300%2C160" alt="A special jubilee anniversary memorial ceremony held for patriotic Gobe in Gondar." width="300" height="160" data-recalc-dims="1" /></noscript></a>
&nbsp;
<h2>Ethiopian All Parties Stakeholders Convention, Seattle Declaration</h2>
<a href="https://ecadforum.com/2018/02/28/ethiopian-all-parties-stakeholders-convention-seattle-declaration/" rel="nofollow"><img src="https://ecadforum.com/wp-content/plugins/jetpack/modules/lazy-images/images/1x1.trans.x41962.gif" alt="Four days long 26 Ethiopian civic and political organizations convention held in Seattle." width="300" height="160" class="aligncenter size-medium wp-image-40470" data-recalc-dims="1" data-lazy-src="https://i1.wp.com/ecadforum.com/wp-content/uploads/2018/02/Seattle-Convention.jpg?resize=300%2C160"><noscript><img src="https://i1.wp.com/ecadforum.com/wp-content/uploads/2018/02/Seattle-Convention.jpg?resize=300%2C160" alt="Four days long 26 Ethiopian civic and political organizations convention held in Seattle." width="300" height="160" class="aligncenter size-medium wp-image-40470" data-recalc-dims="1" /></noscript></a></div></div></div> <div id="ads300_600-widget-4" class="ads300-600">
<div class="ad-cell">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-4379286819423322" data-ad-slot="5792721206"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
</div>
<div id="ads300_600-widget-6" class="ads300-600">
<div class="ad-cell">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-4379286819423322" data-ad-slot="7930606409" data-matched-content-ui-type="image_stacked" data-matched-content-rows-num="5" data-matched-content-columns-num="1" data-ad-format="autorelaxed"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
</div>
<div id="facebook-likebox-3" class="widget widget_facebook_likebox"><div class="widget-top"><h4><a href="https://www.facebook.com/ethiopianews/">Like US on Facebook</a></h4><div class="stripe-line"></div></div>
<div class="widget-container"> <div id="fb-root"></div>
<div class="fb-page" data-href="https://www.facebook.com/ethiopianews/" data-width="300" data-height="250" data-hide-cover="false" data-show-facepile="false" data-show-posts="false">
<div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/ethiopianews/"><a href="https://www.facebook.com/ethiopianews/">Like US on Facebook</a></blockquote></div>
</div>
</div></div></aside>
<div class="clear"></div> <div class="clear"></div>
</div>
</div>
<footer id="theme-footer" class="fade-in animated4">
<div id="footer-widget-area" class="footer-1c container">
<div id="footer-first" class="footer-widgets-box">
<div id="text-html-widget-8" class="text-html-box">
The views, opinions and positions expressed on ECADF Ethiopian News are the opinions of individual contributors and may not necessarily reflect the views of our website. </div>
</div>
</div>
<div class="clear"></div>
</footer>
<div class="clear"></div>
<div class="footer-bottom fade-in animated4">
<div class="container">
<div class="alignleft">
          © Copyright 2016, All Rights Reserved. | <strong><a href="https://ecadforum.com/" target="_blank" rel="nofollow noopener">ECADF Ethiopian News</a></strong>                                            <strong><a href="https://ecadforum.com/" target="_blank" rel="nofollow noopener">Home</a> |  <a href="https://ecadforum.com/Amharic/" target="_blank" rel="nofollow noopener">Amharic</a> |  <a href="https://ecadforum.com/category/video/" target="_blank" rel="nofollow noopener">Video</a> |  <a href="https://ecadforum.com/voa-amharic-radio-daily-broadcast-to-ethiopia/" target="_blank" rel="nofollow noopener">VOA</a>  |  <a href="https://ecadforum.com/contact-2/">Contact Us</a></strong> </div>
</div>
</div>
</div>
<div id="topcontrol" class="tieicon-up-open" title="Scroll To Top"></div>
<div id="fb-root"></div>
<script type='text/javascript' src='https://ecadforum.com/wp-content/plugins/jetpack/_inc/build/photon/photon.min.x41962.js'></script>
<script type='text/javascript' src='https://ecadforum.com/wp-content/plugins/anti-spam/js/anti-spam-4.4.x41962.js'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var tie = {"go_to":"Go to...","ajaxurl":"https:\/\/ecadforum.com\/wp-admin\/admin-ajax.php","your_rating":"Your Rating:","is_singular":"1","reading_indicator":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://ecadforum.com/wp-content/themes/jarida/js/tie-scripts.x41962.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jpfbembed = {"appid":"249643311490","locale":"en_US"};
/* ]]> */
</script>
<script type='text/javascript' src='https://ecadforum.com/wp-content/plugins/jetpack/_inc/build/facebook-embed.min.x41962.js'></script>
<script type='text/javascript' src='https://ecadforum.com/wp-content/plugins/jetpack/_inc/build/lazy-images/js/lazy-images.min.x41962.js'></script>
<script type='text/javascript' src='https://ecadforum.com/wp-includes/js/wp-embed.min.x41962.js'></script>
<script async="async" type='text/javascript' src='https://ecadforum.com/wp-content/plugins/akismet/_inc/form.x41962.js'></script>

<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=787806777997466&version=v2.3";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>
</body>
</html>
